aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorSven Eckelmann <sven@narfation.org>2020-10-22 10:52:08 +0200
committerDavid Bauer <mail@david-bauer.net>2020-10-28 00:11:12 +0100
commit7ca9b82c389a643e81709b58e4e785a5de91330a (patch)
treedbd314207bdafe1dc8204bd0aa0c37bd22babe04 /package/kernel/mac80211
parent83d40aef13e811c2744c2f7d2c3175a5bbb6af43 (diff)
downloadupstream-7ca9b82c389a643e81709b58e4e785a5de91330a.tar.gz
upstream-7ca9b82c389a643e81709b58e4e785a5de91330a.tar.bz2
upstream-7ca9b82c389a643e81709b58e4e785a5de91330a.zip
mac80211: Fix wpa_supplicant config removal ubus call
If mac80211_setup_supplicant() is called with enabled=0 then it should just destroy the interface and remove the configuration from wpa_supplicant. But the ubus method call always returned Command failed: Method not found because the actual name of the method is "config_remove". Fixes: b5516603dd90 ("mac80211: more wifi reconf related fixes") Signed-off-by: Sven Eckelmann <sven@narfation.org> [bump PKG_RELEASE] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index bf88484b78..8448350acf 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=5.8-1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.8/
PKG_HASH:=19b4174d89bf11ee221458e11f1e8dace26558498774b823051156f522d2036b
diff --git a/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh b/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh
index 11ea700b98..6ca12084cf 100644
--- a/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh
+++ b/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh
@@ -627,7 +627,7 @@ mac80211_setup_supplicant() {
local spobj="$(ubus -S list | grep wpa_supplicant.${ifname})"
[ "$enable" = 0 ] && {
- ubus call wpa_supplicant.${phy} config_del "{\"iface\":\"$ifname\"}"
+ ubus call wpa_supplicant.${phy} config_remove "{\"iface\":\"$ifname\"}"
ip link set dev "$ifname" down
iw dev "$ifname" del
return 0