aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-12-02 16:41:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-12-02 16:41:03 +0000
commit498d84fc4e00ad75514c3a9dde09338552b89a8c (patch)
treec356de13fce36967a6069a2b470b070eafdc6690 /package/kernel/mac80211
parentc9902e141e021a683e871d594ddd15a978def1d5 (diff)
downloadupstream-498d84fc4e00ad75514c3a9dde09338552b89a8c.tar.gz
upstream-498d84fc4e00ad75514c3a9dde09338552b89a8c.tar.bz2
upstream-498d84fc4e00ad75514c3a9dde09338552b89a8c.zip
netifd: add wireless configuration support and port mac80211 to the new framework
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 38988
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/Makefile5
-rw-r--r--package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh443
-rw-r--r--package/kernel/mac80211/files/lib/wifi/mac80211.sh532
3 files changed, 446 insertions, 534 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index aafa28bd1e..21b8bb517c 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -72,7 +72,7 @@ endef
define KernelPackage/mac80211
$(call KernelPackage/mac80211/Default)
TITLE:=Linux 802.11 Wireless Networking Stack
- DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-cfg80211
+ DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-cfg80211 +hostapd-common
KCONFIG:=\
CONFIG_AVERAGE=y
FILES:= $(PKG_BUILD_DIR)/net/mac80211/mac80211.ko
@@ -1537,8 +1537,9 @@ define KernelPackage/libertas-sd/install
endef
define KernelPackage/cfg80211/install
- $(INSTALL_DIR) $(1)/lib/wifi
+ $(INSTALL_DIR) $(1)/lib/wifi $(1)/lib/netifd/wireless
$(INSTALL_DATA) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi
+ $(INSTALL_BIN) ./files/lib/netifd/wireless/mac80211.sh $(1)/lib/netifd/wireless
endef
define KernelPackage/p54-pci/install
diff --git a/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh b/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh
new file mode 100644
index 0000000000..eefe1fed5d
--- /dev/null
+++ b/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh
@@ -0,0 +1,443 @@
+#!/bin/sh
+. /lib/netifd/netifd-wireless.sh
+. /lib/netifd/hostapd.sh
+
+init_wireless_driver "$@"
+
+MP_CONFIG_INT="mesh_retry_timeout mesh_confirm_timeout mesh_holding_timeout mesh_max_peer_links
+ mesh_max_retries mesh_ttl mesh_element_ttl mesh_hwmp_max_preq_retries
+ mesh_path_refresh_time mesh_min_discovery_timeout mesh_hwmp_active_path_timeout
+ mesh_hwmp_preq_min_interval mesh_hwmp_net_diameter_traversal_time mesh_hwmp_rootmode
+ mesh_hwmp_rann_interval mesh_gate_announcements mesh_sync_offset_max_neighor
+ mesh_rssi_threshold mesh_hwmp_active_path_to_root_timeout mesh_hwmp_root_interval
+ mesh_hwmp_confirmation_interval mesh_awake_window mesh_plink_timeout"
+MP_CONFIG_BOOL="mesh_auto_open_plinks mesh_fwding"
+MP_CONFIG_STRING="mesh_power_mode"
+
+drv_mac80211_init_device_config() {
+ hostapd_common_add_device_config
+
+ config_add_string path phy macaddr
+ config_add_string hwmode
+ config_add_int beacon_int chanbw frag rts
+ config_add_int rxantenna txantenna antenna_gain txpower
+ config_add_boolean noscan
+ config_add_array ht_capab
+}
+
+drv_mac80211_init_iface_config() {
+ hostapd_common_add_bss_config
+
+ config_add_string macaddr
+
+ config_add_boolean wds powersave
+ config_add_int maxassoc
+ config_add_int max_listen_int
+ config_add_int dtim_interval
+
+ # mesh
+ config_add_int $MP_CONFIG_INT
+ config_add_boolean $MP_CONFIG_BOOL
+ config_add_string $MP_CONFIG_STRING
+}
+
+mac80211_hostapd_setup_base() {
+ local phy="$1"
+
+ json_select config
+
+ [ "$auto_channel" -gt 0 ] && channel=acs_survey
+
+ [ "$enable_ht" -gt 0 ] && {
+ json_get_vars noscan htmode
+ json_get_values ht_capab_list ht_capab
+
+ append base_cfg "ieee80211n=1" "$N"
+
+ ht_capab=
+ [ -n "$htmode" ] && ht_capab="[$htmode]"
+ for cap in $ht_capab_list; do
+ ht_capab="$ht_capab[$cap]"
+ done
+
+ [ -n "$ht_capab" ] && append base_cfg "ht_capab=$ht_capab" "$N"
+ }
+
+ hostapd_prepare_device_config "$hostapd_conf_file" nl80211
+ cat >> "$hostapd_conf_file" <<EOF
+${channel:+channel=$channel}
+${noscan:+noscan=$noscan}
+$base_cfg
+
+EOF
+ json_select ..
+}
+
+mac80211_hostapd_setup_bss() {
+ local phy="$1"
+ local ifname="$2"
+ local macaddr="$3"
+ local type="$4"
+
+ hostapd_cfg=
+ append hostapd_cfg "$type=$ifname" "$N"
+
+ hostapd_set_bss_options hostapd_cfg "$vif" || return 1
+ json_get_vars wds dtim_period max_listen_int
+
+ [ "$wds" -gt 0 ] && append hostapd_cfg "wds_sta=1" "$N"
+ [ "$staidx" -gt 0 ] && append hostapd_cfg "start_disabled=1" "$N"
+
+ cat >> /var/run/hostapd-$phy.conf <<EOF
+$hostapd_cfg
+bssid=$macaddr
+${dtim_period:+dtim_period=$dtim_period}
+${max_listen_int:+max_listen_interval=$max_listen_int}
+EOF
+}
+
+mac80211_generate_mac() {
+ local phy="$1"
+ local id="${macidx:-0}"
+
+ local ref="$(cat /sys/class/ieee80211/${phy}/macaddress)"
+ local mask="$(cat /sys/class/ieee80211/${phy}/address_mask)"
+
+ [ "$mask" = "00:00:00:00:00:00" ] && mask="ff:ff:ff:ff:ff:ff";
+ local oIFS="$IFS"; IFS=":"; set -- $mask; IFS="$oIFS"
+
+ local mask1=$1
+ local mask6=$6
+
+ local oIFS="$IFS"; IFS=":"; set -- $ref; IFS="$oIFS"
+
+ macidx=$(($id + 1))
+ [ "$((0x$mask1))" -gt 0 ] && {
+ b1="0x$1"
+ [ "$id" -gt 0 ] && \
+ b1=$(($b1 ^ ((($id - 1) << 2) | 0x2)))
+ printf "%02x:%s:%s:%s:%s:%s" $b1 $2 $3 $4 $5 $6
+ return
+ }
+
+ [ "$((0x$mask6))" -lt 255 ] && {
+ printf "%s:%s:%s:%s:%s:%02x" $1 $2 $3 $4 $5 $(( 0x$6 ^ $id ))
+ return
+ }
+
+ off2=$(( (0x$6 + $id) / 0x100 ))
+ printf "%s:%s:%s:%s:%02x:%02x" \
+ $1 $2 $3 $4 \
+ $(( (0x$5 + $off2) % 0x100 )) \
+ $(( (0x$6 + $id) % 0x100 ))
+}
+
+find_phy() {
+ [ -n "$phy" -a -d /sys/class/ieee80211/$phy ] && return 0
+ [ -n "$path" -a -d "/sys/devices/$path/ieee80211" ] && {
+ phy="$(ls /sys/devices/$path/ieee80211 | grep -m 1 phy)"
+ [ -n "$phy" ] && return 0
+ }
+ [ -n "$macaddr" ] && {
+ for phy in $(ls /sys/class/ieee80211 2>/dev/null); do
+ grep -i -q "$macaddr" "/sys/class/ieee80211/${phy}/macaddress" && return 0
+ done
+ }
+ return 1
+}
+
+mac80211_check_ap() {
+ has_ap=1
+}
+
+mac80211_prepare_vif() {
+ json_select config
+
+ json_get_vars ifname mode ssid wds powersave macaddr
+
+ [ -n "$ifname" ] || ifname="wlan${phy#phy}${if_idx:+-$if_idx}"
+ if_idx=$((${if_idx:-0} + 1))
+
+ set_default wds 0
+ set_default powersave 0
+
+ json_select ..
+
+ [ -n "$macaddr" ] || {
+ macaddr="$(mac80211_generate_mac $phy)"
+ macidx="$(($macidx + 1))"
+ }
+
+ json_add_object data
+ json_add_string ifname "$ifname"
+ json_close_object
+ json_select config
+
+ # It is far easier to delete and create the desired interface
+ case "$mode" in
+ adhoc)
+ iw phy "$phy" interface add "$ifname" type adhoc
+ ;;
+ ap)
+ # Hostapd will handle recreating the interface and
+ # subsequent virtual APs belonging to the same PHY
+ if [ -n "$hostapd_ctrl" ]; then
+ type=bss
+ else
+ type=interface
+ fi
+
+ mac80211_hostapd_setup_bss "$phy" "$ifname" "$macaddr" "$type" || return
+
+ [ -n "$hostapd_ctrl" ] || {
+ iw phy "$phy" interface add "$ifname" type managed
+ hostapd_ctrl="${hostapd_ctrl:-/var/run/hostapd/$ifname}"
+ }
+ ;;
+ mesh)
+ json_get_vars key mesh_id
+ if [ -n "$key" ]; then
+ iw phy "$phy" interface add "$ifname" type mp
+ else
+ iw phy "$phy" interface add "$ifname" type mp mesh_id "$mesh_id"
+ fi
+ ;;
+ monitor)
+ iw phy "$phy" interface add "$ifname" type monitor
+ ;;
+ sta)
+ local wdsflag=
+ staidx="$(($staidx + 1))"
+ [ "$wds" -gt 0 ] && wdsflag="4addr on"
+ iw phy "$phy" interface add "$ifname" type managed $wdsflag
+ [ "$powersave" -gt 0 ] && powersave="on" || powersave="off"
+ iw "$ifname" set power_save "$powersave"
+ ;;
+ esac
+
+ case "$mode" in
+ monitor|mesh)
+ [ "$auto_channel" -gt 0 ] || iw dev "$ifname" set channel "$channel" $htmode
+ ;;
+ esac
+
+ if [ "$mode" != "ap" ]; then
+ # ALL ap functionality will be passed to hostapd
+ # All interfaces must have unique mac addresses
+ # which can either be explicitly set in the device
+ # section, or automatically generated
+ ifconfig "$ifname" hw ether "$macaddr"
+ fi
+
+ json_select ..
+}
+
+mac80211_setup_supplicant() {
+ wpa_supplicant_prepare_interface "$ifname" nl80211 || return 1
+ wpa_supplicant_add_network "$ifname"
+ wpa_supplicant_run "$ifname" ${hostapd_ctrl:+-H $hostapd_ctrl}
+}
+
+mac80211_setup_adhoc() {
+ json_get_vars bssid ssid basic_rate key
+
+ keyspec=
+ [ "$auth_type" == "wep" ] && {
+ set_default key 1
+ case "$key" in
+ [1234])
+ local idx
+ for idx in 1 2 3 4; do
+ json_get_var ikey "key$idx"
+
+ [ -n "$ikey" ] && {
+ ikey="$(($idx - 1)):$(prepare_key_wep "$ikey")"
+ [ $idx -eq $key ] && ikey="d:$ikey"
+ append keyspec "$ikey"
+ }
+ done
+ ;;
+ *)
+ append keyspec "d:0:$(prepare_key_wep "$key")"
+ ;;
+ esac
+ }
+
+ brstr=
+ for br in $basic_rate; do
+ hostapd_add_rate brstr "$br"
+ done
+
+ mcval=
+ [ -n "$mcast_rate" ] && hostapd_add_rate mcval "$mcast_rate"
+
+ iw dev "$ifname" ibss join "$ssid" $freq $htmode \
+ ${fixed:+fixed-freq} $bssid \
+ ${beacon_int:+beacon-interval $beacon_int} \
+ ${brstr:+basic-rates $brstr} \
+ ${mcval:+mcast-rate $mcval} \
+ ${keyspec:+keys $keyspec}
+}
+
+mac80211_setup_vif() {
+ local name="$1"
+
+ json_select data
+ json_get_vars ifname
+ json_select ..
+
+ json_select config
+ json_get_vars mode
+ json_get_var vif_txpower txpower
+
+ ifconfig "$ifname" up || {
+ wireless_setup_vif_failed IFUP_ERROR
+ json_select ..
+ return
+ }
+
+ set_default vif_txpower "$txpower"
+ [ -z "$vif_txpower" ] || iw dev "$ifname" set txpower fixed "${vif_txpower%%.*}00"
+
+ case "$mode" in
+ mesh)
+ for var in $MP_CONFIG_INT $MP_CONFIG_BOOL $MP_CONFIG_STRING; do
+ json_get_var mp_val "$var"
+ [ -n "$mp_val" ] && iw dev "$ifname" set mesh_param "$var" "$mp_val"
+ done
+ # todo: authsae
+ ;;
+ adhoc)
+ wireless_vif_parse_encryption
+ if [ "$wpa" -gt 0 ]; then
+ mac80211_setup_supplicant || failed=1
+ else
+ mac80211_setup_adhoc
+ fi
+ ;;
+ sta)
+ mac80211_setup_supplicant || failed=1
+ ;;
+ esac
+
+ json_select ..
+ [ -n "$failed" ] || wireless_add_vif "$name" "$ifname"
+}
+
+get_freq() {
+ local phy="$1"
+ local chan="$2"
+ iw "$phy" info | grep -E -m1 "(\* ${chan:-....} MHz${chan:+|\\[$chan\\]})" | grep MHz | awk '{print $2}'
+}
+
+mac80211_interface_cleanup() {
+ local phy="$1"
+
+ for wdev in $(list_phy_interfaces "$phy"); do
+ ifconfig "$wdev" down 2>/dev/null
+ iw dev "$wdev" del
+ done
+}
+
+drv_mac80211_cleanup() {
+ hostapd_common_cleanup
+}
+
+drv_mac80211_setup() {
+ json_select config
+ json_get_vars \
+ phy macaddr path \
+ country chanbw distance \
+ txpower antenna_gain \
+ rxantenna txantenna \
+ frag rts beacon_int
+ json_select ..
+
+ find_phy || {
+ echo "Could not find PHY for device '$1'"
+ wireless_set_retry 0
+ return 1
+ }
+
+ wireless_set_data phy="$phy"
+ mac80211_interface_cleanup "$phy"
+
+ # convert channel to frequency
+ [ "$auto_channel" -gt 0 ] || freq="$(get_freq "$phy" "$channel")"
+
+ [ -n "$country" ] && {
+ iw reg get | grep -q "^country $country:" || {
+ iw reg set "$country"
+ sleep 1
+ }
+ }
+
+ hostapd_conf_file="/var/run/hostapd-$phy.conf"
+
+ no_ap=1
+ macidx=0
+ staidx=0
+
+ [ -n "$chanbw" ] && {
+ for file in /sys/kernel/debug/ieee80211/$phy/ath9k/chanbw /sys/kernel/debug/ieee80211/$phy/ath5k/bwmode; do
+ [ -f "$file" ] && echo "$chanbw" > "$file"
+ done
+ }
+
+ set_default rxantenna all
+ set_default txantenna all
+ set_default distance 0
+ set_default antenna_gain 0
+
+ iw phy "$phy" set antenna $txantenna $rxantenna >/dev/null 2>&1
+ iw phy "$phy" set antenna_gain $antenna_gain
+ iw phy "$phy" set distance "$distance"
+
+ [ -n "$frag" ] && iw phy "$phy" set frag "${frag%%.*}"
+ [ -n "$rts" ] && iw phy "$phy" set rts "${rts%%.*}"
+
+ has_ap=
+ hostapd_ctrl=
+ for_each_interface "ap" mac80211_check_ap
+
+ rm -f "$hostapd_conf_file"
+ [ -n "$has_ap" ] && mac80211_hostapd_setup_base "$phy"
+
+ for_each_interface "sta adhoc mesh monitor" mac80211_prepare_vif
+ for_each_interface "ap" mac80211_prepare_vif
+
+ [ -n "$hostapd_ctrl" ] && {
+ /usr/sbin/hostapd -P /var/run/wifi-$phy.pid -B "$hostapd_conf_file"
+ ret="$?"
+ wireless_add_process "$(cat /var/run/wifi-$phy.pid)" "/usr/sbin/hostapd" 1
+ [ "$ret" != 0 ] && {
+ wireless_setup_failed HOSTAPD_START_FAILED
+ return
+ }
+ }
+
+ for_each_interface "ap sta adhoc mesh monitor" mac80211_setup_vif
+
+ wireless_set_up
+}
+
+list_phy_interfaces() {
+ local phy="$1"
+ if [ -d "/sys/class/ieee80211/${phy}/device/net" ]; then
+ ls "/sys/class/ieee80211/${phy}/device/net" 2>/dev/null;
+ else
+ ls "/sys/class/ieee80211/${phy}/device" 2>/dev/null | grep net: | sed -e 's,net:,,g'
+ fi
+}
+
+drv_mac80211_teardown() {
+ wireless_process_kill_all
+
+ json_select data
+ json_get_vars phy
+ json_select ..
+
+ mac80211_interface_cleanup "$phy"
+}
+
+add_driver mac80211
diff --git a/package/kernel/mac80211/files/lib/wifi/mac80211.sh b/package/kernel/mac80211/files/lib/wifi/mac80211.sh
index 1994ca38d4..e33b09abb2 100644
--- a/package/kernel/mac80211/files/lib/wifi/mac80211.sh
+++ b/package/kernel/mac80211/files/lib/wifi/mac80211.sh
@@ -1,166 +1,6 @@
#!/bin/sh
append DRIVERS "mac80211"
-mac80211_hostapd_setup_base() {
- local phy="$1"
- local ifname="$2"
-
- cfgfile="/var/run/hostapd-$phy.conf"
-
- config_get device "$vif" device
- config_get country "$device" country
- config_get hwmode "$device" hwmode
- config_get channel "$device" channel
- config_get beacon_int "$device" beacon_int
- config_get basic_rate_list "$device" basic_rate
- config_get_bool noscan "$device" noscan
-
- hostapd_set_log_options base_cfg "$device"
-
- [ -n "$channel" -a -z "$hwmode" ] && wifi_fixup_hwmode "$device"
-
- hostapd_channel=$channel
- [ "$channel" = auto -o "$channel" = 0 ] && hostapd_channel=acs_survey
-
- [ -n "$hwmode" ] && {
- config_get hwmode_11n "$device" hwmode_11n
- [ -n "$hwmode_11n" ] && {
- hwmode="$hwmode_11n"
- append base_cfg "ieee80211n=1" "$N"
- config_get htmode "$device" htmode
- config_get ht_capab_list "$device" ht_capab
- case "$htmode" in
- HT20|HT40+|HT40-) ht_capab="[$htmode]";;
- *)ht_capab=;;
- esac
- for cap in $ht_capab_list; do
- ht_capab="$ht_capab[$cap]"
- done
- [ -n "$ht_capab" ] && append base_cfg "ht_capab=$ht_capab" "$N"
- }
- }
-
- local country_ie=0
- [ -n "$country" ] && country_ie=1
- config_get_bool country_ie "$device" country_ie "$country_ie"
- [ "$country_ie" -gt 0 ] && append base_cfg "ieee80211d=1" "$N"
-
- local br brval brstr
- [ -n "$basic_rate_list" ] && {
- for br in $basic_rate_list; do
- brval="$(($br / 100))"
- [ -n "$brstr" ] && brstr="$brstr "
- brstr="$brstr$brval"
- done
- }
-
- cat >> "$cfgfile" <<EOF
-ctrl_interface=/var/run/hostapd-$phy
-driver=nl80211
-wmm_ac_bk_cwmin=4
-wmm_ac_bk_cwmax=10
-wmm_ac_bk_aifs=7
-wmm_ac_bk_txop_limit=0
-wmm_ac_bk_acm=0
-wmm_ac_be_aifs=3
-wmm_ac_be_cwmin=4
-wmm_ac_be_cwmax=10
-wmm_ac_be_txop_limit=0
-wmm_ac_be_acm=0
-wmm_ac_vi_aifs=2
-wmm_ac_vi_cwmin=3
-wmm_ac_vi_cwmax=4
-wmm_ac_vi_txop_limit=94
-wmm_ac_vi_acm=0
-wmm_ac_vo_aifs=2
-wmm_ac_vo_cwmin=2
-wmm_ac_vo_cwmax=3
-wmm_ac_vo_txop_limit=47
-wmm_ac_vo_acm=0
-tx_queue_data3_aifs=7
-tx_queue_data3_cwmin=15
-tx_queue_data3_cwmax=1023
-tx_queue_data3_burst=0
-tx_queue_data2_aifs=3
-tx_queue_data2_cwmin=15
-tx_queue_data2_cwmax=63
-tx_queue_data2_burst=0
-tx_queue_data1_aifs=1
-tx_queue_data1_cwmin=7
-tx_queue_data1_cwmax=15
-tx_queue_data1_burst=3.0
-tx_queue_data0_aifs=1
-tx_queue_data0_cwmin=3
-tx_queue_data0_cwmax=7
-tx_queue_data0_burst=1.5
-${hwmode:+hw_mode=$hwmode}
-${hostapd_channel:+channel=$hostapd_channel}
-${beacon_int:+beacon_int=$beacon_int}
-${country:+country_code=$country}
-${noscan:+noscan=$noscan}
-${brstr:+basic_rates=$brstr}
-$base_cfg
-
-EOF
-}
-
-mac80211_hostapd_setup_bss() {
- local phy="$1"
- local vif="$2"
- local staidx="$3"
-
- hostapd_cfg=
- cfgfile="/var/run/hostapd-$phy.conf"
- config_get ifname "$vif" ifname
-
- if [ -f "$cfgfile" ]; then
- append hostapd_cfg "bss=$ifname" "$N"
- else
- mac80211_hostapd_setup_base "$phy" "$ifname"
- append hostapd_cfg "interface=$ifname" "$N"
- fi
-
- local net_cfg bridge
- net_cfg="$(find_net_config "$vif")"
- [ -z "$net_cfg" ] || bridge="$(bridge_interface "$net_cfg")"
- config_set "$vif" bridge "$bridge"
-
- hostapd_set_bss_options hostapd_cfg "$vif"
-
- config_get_bool wds "$vif" wds 0
- [ "$wds" -gt 0 ] && append hostapd_cfg "wds_sta=1" "$N"
-
- [ "$staidx" -gt 0 ] && append hostapd_cfg "start_disabled=1" "$N"
-
- local macaddr hidden maxassoc wmm
- config_get macaddr "$vif" macaddr
- config_get maxassoc "$vif" maxassoc
- config_get dtim_period "$vif" dtim_period
- config_get max_listen_int "$vif" max_listen_int
- config_get_bool hidden "$vif" hidden 0
- config_get_bool wmm "$vif" wmm 1
- cat >> /var/run/hostapd-$phy.conf <<EOF
-$hostapd_cfg
-wmm_enabled=$wmm
-bssid=$macaddr
-ignore_broadcast_ssid=$hidden
-${dtim_period:+dtim_period=$dtim_period}
-${max_listen_int:+max_listen_interval=$max_listen_int}
-${maxassoc:+max_num_sta=$maxassoc}
-EOF
-}
-
-mac80211_start_vif() {
- local vif="$1"
- local ifname="$2"
-
- local net_cfg
- net_cfg="$(find_net_config "$vif")"
- [ -z "$net_cfg" ] || start_net "$ifname" "$net_cfg"
-
- set_wifi_up "$vif" "$ifname"
-}
-
lookup_phy() {
[ -n "$phy" ] && {
[ -d /sys/class/ieee80211/$phy ] && return
@@ -204,378 +44,6 @@ find_mac80211_phy() {
return 0
}
-scan_mac80211() {
- local device="$1"
- local adhoc sta ap monitor mesh disabled
-
- config_get vifs "$device" vifs
- for vif in $vifs; do
- config_get_bool disabled "$vif" disabled 0
- [ $disabled = 0 ] || continue
-
- config_get mode "$vif" mode
- case "$mode" in
- adhoc|sta|ap|monitor|mesh)
- append $mode "$vif"
- ;;
- *) echo "$device($vif): Invalid mode, ignored."; continue;;
- esac
- done
-
- config_set "$device" vifs "${ap:+$ap }${adhoc:+$adhoc }${sta:+$sta }${monitor:+$monitor }${mesh:+$mesh}"
-}
-
-list_phy_interfaces() {
- local phy="$1"
- if [ -d "/sys/class/ieee80211/${phy}/device/net" ]; then
- ls "/sys/class/ieee80211/${phy}/device/net" 2>/dev/null;
- else
- ls "/sys/class/ieee80211/${phy}/device" 2>/dev/null | grep net: | sed -e 's,net:,,g'
- fi
-}
-
-disable_mac80211() (
- local device="$1"
-
- find_mac80211_phy "$device" || return 0
- config_get phy "$device" phy
-
- set_wifi_down "$device"
- # kill all running hostapd and wpa_supplicant processes that
- # are running on atheros/mac80211 vifs
- for pid in `pidof hostapd`; do
- grep -E "$phy" /proc/$pid/cmdline >/dev/null && \
- kill $pid
- done
-
- include /lib/network
- for wdev in $(list_phy_interfaces "$phy"); do
- [ -f "/var/run/$wdev.pid" ] && kill $(cat /var/run/$wdev.pid) >&/dev/null 2>&1
- for pid in `pidof wpa_supplicant meshd-nl80211`; do
- grep "$wdev" /proc/$pid/cmdline >/dev/null && \
- kill $pid
- done
- ifconfig "$wdev" down 2>/dev/null
- unbridge "$dev"
- iw dev "$wdev" del
- done
-
- return 0
-)
-
-get_freq() {
- local phy="$1"
- local chan="$2"
- iw "$phy" info | grep -E -m1 "(\* ${chan:-....} MHz${chan:+|\\[$chan\\]})" | grep MHz | awk '{print $2}'
-}
-
-mac80211_generate_mac() {
- local id="$1"
- local ref="$2"
- local mask="$3"
-
- [ "$mask" = "00:00:00:00:00:00" ] && mask="ff:ff:ff:ff:ff:ff";
- local oIFS="$IFS"; IFS=":"; set -- $mask; IFS="$oIFS"
-
- local mask1=$1
- local mask6=$6
-
- local oIFS="$IFS"; IFS=":"; set -- $ref; IFS="$oIFS"
- [ "$((0x$mask1))" -gt 0 ] && {
- b1="0x$1"
- [ "$id" -gt 0 ] && \
- b1=$(($b1 ^ ((($id - 1) << 2) | 0x2)))
- printf "%02x:%s:%s:%s:%s:%s" $b1 $2 $3 $4 $5 $6
- return
- }
-
- [ "$((0x$mask6))" -lt 255 ] && {
- printf "%s:%s:%s:%s:%s:%02x" $1 $2 $3 $4 $5 $(( 0x$6 ^ $id ))
- return
- }
-
- off2=$(( (0x$6 + $id) / 0x100 ))
- printf "%s:%s:%s:%s:%02x:%02x" \
- $1 $2 $3 $4 \
- $(( (0x$5 + $off2) % 0x100 )) \
- $(( (0x$6 + $id) % 0x100 ))
-}
-
-enable_mac80211() {
- local device="$1"
- config_get channel "$device" channel
- config_get vifs "$device" vifs
- config_get txpower "$device" txpower
- config_get country "$device" country
- config_get distance "$device" distance
- config_get txantenna "$device" txantenna all
- config_get rxantenna "$device" rxantenna all
- config_get antenna_gain "$device" antenna_gain 0
- config_get frag "$device" frag
- config_get rts "$device" rts
- find_mac80211_phy "$device" || return 0
- config_get phy "$device" phy
- local i=0
- local macidx=0
- local apidx=0
- local staidx=0
- fixed=""
- local hostapd_ctrl=""
-
- [ -n "$country" ] && {
- iw reg get | grep -q "^country $country:" || {
- iw reg set "$country"
- sleep 1
- }
- }
-
- config_get chanbw "$device" chanbw
- [ -n "$chanbw" -a -d /sys/kernel/debug/ieee80211/$phy/ath9k ] && echo "$chanbw" > /sys/kernel/debug/ieee80211/$phy/ath9k/chanbw
- [ -n "$chanbw" -a -d /sys/kernel/debug/ieee80211/$phy/ath5k ] && echo "$chanbw" > /sys/kernel/debug/ieee80211/$phy/ath5k/bwmode
-
- [ "$channel" = "auto" -o "$channel" = "0" ] || {
- fixed=1
- }
-
- iw phy "$phy" set antenna $txantenna $rxantenna >/dev/null 2>&1
- iw phy "$phy" set antenna_gain $antenna_gain
-
- [ -n "$distance" ] && iw phy "$phy" set distance "$distance"
- [ -n "$frag" ] && iw phy "$phy" set frag "${frag%%.*}"
- [ -n "$rts" ] && iw phy "$phy" set rts "${rts%%.*}"
-
- export channel fixed
- # convert channel to frequency
- local freq="$(get_freq "$phy" "${fixed:+$channel}")"
-
- wifi_fixup_hwmode "$device" "g"
- for vif in $vifs; do
- config_get ifname "$vif" ifname
- [ -n "$ifname" ] || {
- [ $i -gt 0 ] && ifname="wlan${phy#phy}-$i" || ifname="wlan${phy#phy}"
- }
- config_set "$vif" ifname "$ifname"
-
- config_get mode "$vif" mode
- config_get ssid "$vif" ssid
-
- # It is far easier to delete and create the desired interface
- case "$mode" in
- adhoc)
- iw phy "$phy" interface add "$ifname" type adhoc
- ;;
- ap)
- # Hostapd will handle recreating the interface and
- # it's accompanying monitor
- apidx="$(($apidx + 1))"
- [ "$apidx" -gt 1 ] || iw phy "$phy" interface add "$ifname" type managed
- ;;
- mesh)
- config_get key "$vif" key ""
- if [ -n "$key" ]; then
- iw phy "$phy" interface add "$ifname" type mp
- else
- config_get mesh_id "$vif" mesh_id
- iw phy "$phy" interface add "$ifname" type mp mesh_id "$mesh_id"
- fi
- ;;
- monitor)
- iw phy "$phy" interface add "$ifname" type monitor
- ;;
- sta)
- local wdsflag
- staidx="$(($staidx + 1))"
- config_get_bool wds "$vif" wds 0
- [ "$wds" -gt 0 ] && wdsflag="4addr on"
- iw phy "$phy" interface add "$ifname" type managed $wdsflag
- config_get_bool powersave "$vif" powersave 0
- [ "$powersave" -gt 0 ] && powersave="on" || powersave="off"
- iw "$ifname" set power_save "$powersave"
- ;;
- esac
-
- # All interfaces must have unique mac addresses
- # which can either be explicitly set in the device
- # section, or automatically generated
- config_get macaddr "$device" macaddr
- config_get vif_mac "$vif" macaddr
- [ -n "$vif_mac" ] || {
- vif_mac="$(mac80211_generate_mac $macidx $macaddr $(cat /sys/class/ieee80211/${phy}/address_mask))"
- macidx="$(($macidx + 1))"
- }
- [ "$mode" = "ap" ] || ifconfig "$ifname" hw ether "$vif_mac"
- config_set "$vif" macaddr "$vif_mac"
-
- # !! ap !!
- #
- # ALL ap functionality will be passed to hostapd
- #
- # !! station !!
- #
- # ALL station functionality will be passed to wpa_supplicant
- #
- if [ ! "$mode" = "ap" ]; then
- # We attempt to set the channel for all interfaces, although
- # mac80211 may not support it or the driver might not yet
- # for ap mode this is handled by hostapd
- config_get htmode "$device" htmode
- case "$htmode" in
- HT20|HT40+|HT40-) ;;
- *) htmode= ;;
- esac
- [ -n "$fixed" -a -n "$channel" ] && iw dev "$ifname" set channel "$channel" $htmode
- fi
-
- i=$(($i + 1))
- done
-
- local start_hostapd=
- rm -f /var/run/hostapd-$phy.conf
- for vif in $vifs; do
- config_get mode "$vif" mode
- case "$mode" in
- ap)
- mac80211_hostapd_setup_bss "$phy" "$vif" "$staidx"
- start_hostapd=1
- ;;
- mesh)
- config_get key "$vif" key ""
- [ -n "$key" ] && authsae_start_interface "$device" "$vif"
- ;;
- esac
- done
-
- [ -n "$start_hostapd" ] && {
- hostapd -P /var/run/wifi-$phy.pid -B /var/run/hostapd-$phy.conf || {
- echo "Failed to start hostapd for $phy"
- return
- }
- sleep 2
-
- for vif in $vifs; do
- config_get mode "$vif" mode
- config_get ifname "$vif" ifname
- [ "$mode" = "ap" ] || continue
- hostapd_ctrl="${hostapd_ctrl:-/var/run/hostapd-$phy/$ifname}"
- mac80211_start_vif "$vif" "$ifname"
- done
- }
-
- for vif in $vifs; do
- config_get mode "$vif" mode
- config_get ifname "$vif" ifname
- [ "$mode" = "ap" ] || ifconfig "$ifname" up
-
- config_get vif_txpower "$vif" txpower
- # use vif_txpower (from wifi-iface) to override txpower (from
- # wifi-device) if the latter doesn't exist
- txpower="${txpower:-$vif_txpower}"
- [ -z "$txpower" ] || iw dev "$ifname" set txpower fixed "${txpower%%.*}00"
-
- case "$mode" in
- adhoc)
- config_get bssid "$vif" bssid
- config_get ssid "$vif" ssid
- config_get beacon_int "$device" beacon_int
- config_get basic_rate_list "$device" basic_rate
- config_get encryption "$vif" encryption
- config_get key "$vif" key 1
- config_get mcast_rate "$vif" mcast_rate
- config_get htmode "$device" htmode
- case "$htmode" in
- HT20|HT40+|HT40-) ;;
- *) htmode= ;;
- esac
-
-
- local keyspec=""
- [ "$encryption" == "psk" -o "$encryption" == "psk2" ] && {
- if eval "type wpa_supplicant_setup_vif" 2>/dev/null >/dev/null; then
- wpa_supplicant_setup_vif "$vif" nl80211 "${hostapd_ctrl:+-H $hostapd_ctrl}" $freq $htmode || {
- echo "enable_mac80211($device): Failed to set up wpa_supplicant for interface $ifname" >&2
- # make sure this wifi interface won't accidentally stay open without encryption
- ifconfig "$ifname" down
- }
- mac80211_start_vif "$vif" "$ifname"
- continue
- fi
- }
-
- [ "$encryption" == "wep" ] && {
- case "$key" in
- [1234])
- local idx
- for idx in 1 2 3 4; do
- local ikey
- config_get ikey "$vif" "key$idx"
-
- [ -n "$ikey" ] && {
- ikey="$(($idx - 1)):$(prepare_key_wep "$ikey")"
- [ $idx -eq $key ] && ikey="d:$ikey"
- append keyspec "$ikey"
- }
- done
- ;;
- *) append keyspec "d:0:$(prepare_key_wep "$key")" ;;
- esac
- }
-
- local br brval brsub brstr
- [ -n "$basic_rate_list" ] && {
- for br in $basic_rate_list; do
- brval="$(($br / 1000))"
- brsub="$((($br / 100) % 10))"
- [ "$brsub" -gt 0 ] && brval="$brval.$brsub"
- [ -n "$brstr" ] && brstr="$brstr,"
- brstr="$brstr$brval"
- done
- }
-
- local mcval=""
- [ -n "$mcast_rate" ] && {
- mcval="$(($mcast_rate / 1000))"
- mcsub="$(( ($mcast_rate / 100) % 10 ))"
- [ "$mcsub" -gt 0 ] && mcval="$mcval.$mcsub"
- }
-
- iw dev "$ifname" ibss join "$ssid" $freq $htmode \
- ${fixed:+fixed-freq} $bssid \
- ${beacon_int:+beacon-interval $beacon_int} \
- ${brstr:+basic-rates $brstr} \
- ${mcval:+mcast-rate $mcval} \
- ${keyspec:+keys $keyspec}
- ;;
- mesh)
- mp_list="mesh_retry_timeout mesh_confirm_timeout mesh_holding_timeout mesh_max_peer_links
- mesh_max_retries mesh_ttl mesh_element_ttl mesh_auto_open_plinks mesh_hwmp_max_preq_retries
- mesh_path_refresh_time mesh_min_discovery_timeout mesh_hwmp_active_path_timeout
- mesh_hwmp_preq_min_interval mesh_hwmp_net_diameter_traversal_time mesh_hwmp_rootmode
- mesh_hwmp_rann_interval mesh_gate_announcements mesh_fwding mesh_sync_offset_max_neighor
- mesh_rssi_threshold mesh_hwmp_active_path_to_root_timeout mesh_hwmp_root_interval
- mesh_hwmp_confirmation_interval mesh_power_mode mesh_awake_window"
- for mp in $mp_list
- do
- config_get mp_val "$vif" "$mp" ""
- [ -n "$mp_val" ] && iw dev "$ifname" set mesh_param "$mp" "$mp_val"
- done
- ;;
- sta)
- if eval "type wpa_supplicant_setup_vif" 2>/dev/null >/dev/null; then
- wpa_supplicant_setup_vif "$vif" nl80211 "${hostapd_ctrl:+-H $hostapd_ctrl}" || {
- echo "enable_mac80211($device): Failed to set up wpa_supplicant for interface $ifname" >&2
- # make sure this wifi interface won't accidentally stay open without encryption
- ifconfig "$ifname" down
- continue
- }
- fi
- ;;
- esac
- [ "$mode" = "ap" ] || mac80211_start_vif "$vif" "$ifname"
- done
-
-}
-
-
check_mac80211_device() {
config_get phy "$1" phy
[ -z "$phy" ] && {