aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/patches/ath/080-ath10k_thermal_config.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-08-02 08:44:29 +0200
committerJohn Crispin <john@phrozen.org>2018-09-26 16:35:33 +0200
commitd9eefa7a7031543571d434693c7f984dfbdc990d (patch)
tree73ac027ccf6cdb6fd209a83e7e25c3d0472d46b4 /package/kernel/mac80211/patches/ath/080-ath10k_thermal_config.patch
parente9d92bf1e1af71ff19e4cdc753de3f65963c58a5 (diff)
downloadupstream-d9eefa7a7031543571d434693c7f984dfbdc990d.tar.gz
upstream-d9eefa7a7031543571d434693c7f984dfbdc990d.tar.bz2
upstream-d9eefa7a7031543571d434693c7f984dfbdc990d.zip
mac80211: rebase ontop of v4.18.5
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/kernel/mac80211/patches/ath/080-ath10k_thermal_config.patch')
-rw-r--r--package/kernel/mac80211/patches/ath/080-ath10k_thermal_config.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/package/kernel/mac80211/patches/ath/080-ath10k_thermal_config.patch b/package/kernel/mac80211/patches/ath/080-ath10k_thermal_config.patch
new file mode 100644
index 0000000000..f008a795d8
--- /dev/null
+++ b/package/kernel/mac80211/patches/ath/080-ath10k_thermal_config.patch
@@ -0,0 +1,55 @@
+Index: backports-v4.18-rc7/drivers/net/wireless/ath/ath10k/Kconfig
+===================================================================
+--- backports-v4.18-rc7.orig/drivers/net/wireless/ath/ath10k/Kconfig
++++ backports-v4.18-rc7/drivers/net/wireless/ath/ath10k/Kconfig
+@@ -85,6 +85,12 @@ config ATH10K_TRACING
+ ---help---
+ Select this to ath10k use tracing infrastructure.
+
++config ATH10K_THERMAL
++ bool "Atheros ath10k thermal monitoring support"
++ depends on THERMAL
++ ---help---
++ Select this to ath10k use hwmon for thermal measurement.
++
+ config ATH10K_DFS_CERTIFIED
+ bool "Atheros DFS support for certified platforms"
+ depends on ATH10K && CFG80211_CERTIFICATION_ONUS
+Index: backports-v4.18-rc7/drivers/net/wireless/ath/ath10k/Makefile
+===================================================================
+--- backports-v4.18-rc7.orig/drivers/net/wireless/ath/ath10k/Makefile
++++ backports-v4.18-rc7/drivers/net/wireless/ath/ath10k/Makefile
+@@ -18,7 +18,7 @@ ath10k_core-y += mac.o \
+ ath10k_core-$(CPTCFG_ATH10K_SPECTRAL) += spectral.o
+ ath10k_core-$(CPTCFG_NL80211_TESTMODE) += testmode.o
+ ath10k_core-$(CPTCFG_ATH10K_TRACING) += trace.o
+-ath10k_core-$(CONFIG_THERMAL) += thermal.o
++ath10k_core-$(CPTCFG_ATH10K_THERMAL) += thermal.o
+ ath10k_core-$(CPTCFG_MAC80211_DEBUGFS) += debugfs_sta.o
+ ath10k_core-$(CONFIG_PM) += wow.o
+ ath10k_core-$(CONFIG_DEV_COREDUMP) += coredump.o
+Index: backports-v4.18-rc7/drivers/net/wireless/ath/ath10k/thermal.h
+===================================================================
+--- backports-v4.18-rc7.orig/drivers/net/wireless/ath/ath10k/thermal.h
++++ backports-v4.18-rc7/drivers/net/wireless/ath/ath10k/thermal.h
+@@ -36,7 +36,7 @@ struct ath10k_thermal {
+ int temperature;
+ };
+
+-#if IS_REACHABLE(CONFIG_THERMAL)
++#if IS_REACHABLE(CPTCFG_ATH10K_THERMAL)
+ int ath10k_thermal_register(struct ath10k *ar);
+ void ath10k_thermal_unregister(struct ath10k *ar);
+ void ath10k_thermal_event_temperature(struct ath10k *ar, int temperature);
+Index: backports-v4.18-rc7/local-symbols
+===================================================================
+--- backports-v4.18-rc7.orig/local-symbols
++++ backports-v4.18-rc7/local-symbols
+@@ -144,6 +144,7 @@ ATH10K_SNOC=
+ ATH10K_DEBUG=
+ ATH10K_DEBUGFS=
+ ATH10K_SPECTRAL=
++ATH10K_THERMAL=
+ ATH10K_TRACING=
+ ATH10K_DFS_CERTIFIED=
+ WCN36XX=