aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/patches/080-ath10k_thermal_config.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-10-17 10:57:43 +0200
committerFelix Fietkau <nbd@nbd.name>2016-10-17 11:01:37 +0200
commit5f9598a432d92c1b60f4f2c724da0912cd3369a1 (patch)
treef1b3a15541ce1577a81769085045392ca801b1ce /package/kernel/mac80211/patches/080-ath10k_thermal_config.patch
parent39f8e46bb40df9c7074132b7132ed3f01bd1b815 (diff)
downloadupstream-5f9598a432d92c1b60f4f2c724da0912cd3369a1.tar.gz
upstream-5f9598a432d92c1b60f4f2c724da0912cd3369a1.tar.bz2
upstream-5f9598a432d92c1b60f4f2c724da0912cd3369a1.zip
mac80211: fix build error in ath10k with hwmon enabled
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mac80211/patches/080-ath10k_thermal_config.patch')
-rw-r--r--package/kernel/mac80211/patches/080-ath10k_thermal_config.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/package/kernel/mac80211/patches/080-ath10k_thermal_config.patch b/package/kernel/mac80211/patches/080-ath10k_thermal_config.patch
new file mode 100644
index 0000000000..e08fa32a3b
--- /dev/null
+++ b/package/kernel/mac80211/patches/080-ath10k_thermal_config.patch
@@ -0,0 +1,37 @@
+--- a/drivers/net/wireless/ath/ath10k/Kconfig
++++ b/drivers/net/wireless/ath/ath10k/Kconfig
+@@ -48,6 +48,12 @@ config ATH10K_TRACING
+ ---help---
+ Select this to ath10k use tracing infrastructure.
+
++config ATH10K_THERMAL
++ bool "Atheros ath10k thermal monitoring support"
++ depends on THERMAL
++ ---help---
++ Select this to ath10k use hwmon for thermal measurement.
++
+ config ATH10K_DFS_CERTIFIED
+ bool "Atheros DFS support for certified platforms"
+ depends on ATH10K && CFG80211_CERTIFICATION_ONUS
+--- a/drivers/net/wireless/ath/ath10k/Makefile
++++ b/drivers/net/wireless/ath/ath10k/Makefile
+@@ -17,7 +17,7 @@ ath10k_core-y += mac.o \
+ ath10k_core-$(CPTCFG_ATH10K_DEBUGFS) += spectral.o
+ ath10k_core-$(CPTCFG_NL80211_TESTMODE) += testmode.o
+ ath10k_core-$(CPTCFG_ATH10K_TRACING) += trace.o
+-ath10k_core-$(CONFIG_THERMAL) += thermal.o
++ath10k_core-$(CPTCFG_ATH10K_THERMAL) += thermal.o
+ ath10k_core-$(CPTCFG_MAC80211_DEBUGFS) += debugfs_sta.o
+ ath10k_core-$(CONFIG_PM) += wow.o
+
+--- a/drivers/net/wireless/ath/ath10k/thermal.h
++++ b/drivers/net/wireless/ath/ath10k/thermal.h
+@@ -36,7 +36,7 @@ struct ath10k_thermal {
+ int temperature;
+ };
+
+-#if IS_REACHABLE(CONFIG_THERMAL)
++#if IS_REACHABLE(CPTCFG_ATH10K_THERMAL)
+ int ath10k_thermal_register(struct ath10k *ar);
+ void ath10k_thermal_unregister(struct ath10k *ar);
+ void ath10k_thermal_event_temperature(struct ath10k *ar, int temperature);