aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/ath.mk
diff options
context:
space:
mode:
authorAlan Swanson <reiver@improbability.net>2020-03-07 15:42:54 +0000
committerJo-Philipp Wich <jo@mein.io>2020-06-18 20:08:18 +0200
commita4c0767fbc50ea50f1f0c5adfa35d1c8d347462b (patch)
tree737682e1142383e1bea487dec57257862d90c32a /package/kernel/mac80211/ath.mk
parenta4248577a00cb2f21bc19ff06492e36b0ae714e6 (diff)
downloadupstream-a4c0767fbc50ea50f1f0c5adfa35d1c8d347462b.tar.gz
upstream-a4c0767fbc50ea50f1f0c5adfa35d1c8d347462b.tar.bz2
upstream-a4c0767fbc50ea50f1f0c5adfa35d1c8d347462b.zip
mac80211: ath9k: enable adding wireless noise to kernel entropy pool
This option allows adding the ath9k ADC register output as a source of randomness into the Linux entropy pool at sufficient quality random data (at least 10 bits and up to 22 bits of min-entropy for a 32-bit value). Fixes FS#1444 Signed-off-by: Alan Swanson <reiver@improbability.net>
Diffstat (limited to 'package/kernel/mac80211/ath.mk')
-rw-r--r--package/kernel/mac80211/ath.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/kernel/mac80211/ath.mk b/package/kernel/mac80211/ath.mk
index 788131b751..352d192fa1 100644
--- a/package/kernel/mac80211/ath.mk
+++ b/package/kernel/mac80211/ath.mk
@@ -7,6 +7,7 @@ PKG_CONFIG_DEPENDS += \
CONFIG_PACKAGE_ATH_DFS \
CONFIG_PACKAGE_ATH_SPECTRAL \
CONFIG_PACKAGE_ATH_DYNACK \
+ CONFIG_ATH9K_HWRNG \
CONFIG_ATH9K_SUPPORT_PCOEM \
CONFIG_ATH9K_TX99 \
CONFIG_ATH10K_LEDS \
@@ -44,6 +45,7 @@ config-$(CONFIG_TARGET_ath79) += ATH9K_AHB
config-$(CONFIG_TARGET_ipq40xx) += ATH10K_AHB
config-$(CONFIG_PCI) += ATH9K_PCI
config-$(CONFIG_ATH_USER_REGD) += ATH_USER_REGD
+config-$(CONFIG_ATH9K_HWRNG) += ATH9K_HWRNG
config-$(CONFIG_ATH9K_SUPPORT_PCOEM) += ATH9K_PCOEM
config-$(CONFIG_ATH9K_TX99) += ATH9K_TX99
config-$(CONFIG_ATH9K_UBNTHSR) += ATH9K_UBNTHSR
@@ -207,6 +209,12 @@ endef
define KernelPackage/ath9k/config
+ config ATH9K_HWRNG
+ bool "Add wireless noise as source of randomness to kernel entropy pool"
+ depends on PACKAGE_kmod-ath9k
+ select PACKAGE_kmod-random-core
+ default n
+
config ATH9K_SUPPORT_PCOEM
bool "Support chips used in PC OEM cards"
depends on PACKAGE_kmod-ath9k