aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/ath.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-07 15:58:52 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-02 16:29:22 +0200
commit7d29a557140381ef1815329f6843b88b4126d490 (patch)
treef754cf1234317e49cee7a5266189bd57a356ad22 /package/kernel/mac80211/ath.mk
parentedb5d2a320adf99ddbb12fbc8a03a5fe7cf7741f (diff)
downloadupstream-7d29a557140381ef1815329f6843b88b4126d490.tar.gz
upstream-7d29a557140381ef1815329f6843b88b4126d490.tar.bz2
upstream-7d29a557140381ef1815329f6843b88b4126d490.zip
ath25: drop target
This target still only works with kernel 4.14, and not so recent attempts of getting newer kernel versions supported did not lead to success. Therefore, drop the target, as we are already two LTS kernel versions ahead and it does not seem like anybody will pick up the work. Patchwork series: https://patchwork.ozlabs.org/project/openwrt/list/?series=169991&state=* Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/kernel/mac80211/ath.mk')
-rw-r--r--package/kernel/mac80211/ath.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/package/kernel/mac80211/ath.mk b/package/kernel/mac80211/ath.mk
index 5db4be8daa..45037738de 100644
--- a/package/kernel/mac80211/ath.mk
+++ b/package/kernel/mac80211/ath.mk
@@ -55,11 +55,7 @@ config-$(call config_package,ath9k-htc) += ATH9K_HTC
config-$(call config_package,ath10k) += ATH10K ATH10K_PCI
config-$(call config_package,ath5k) += ATH5K
-ifdef CONFIG_TARGET_ath25
- config-y += ATH5K_AHB
-else
- config-y += ATH5K_PCI
-endif
+config-y += ATH5K_PCI
config-$(call config_package,ath6kl) += ATH6KL
config-$(call config_package,ath6kl-sdio) += ATH6KL_SDIO
@@ -121,7 +117,7 @@ endef
define KernelPackage/ath
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros common driver part
- DEPENDS+= @PCI_SUPPORT||USB_SUPPORT||TARGET_ath79||TARGET_ath25 +kmod-mac80211
+ DEPENDS+= @PCI_SUPPORT||USB_SUPPORT||TARGET_ath79 +kmod-mac80211
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath.ko
MENU:=1
endef
@@ -134,7 +130,7 @@ define KernelPackage/ath5k
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros 5xxx wireless cards support
URL:=https://wireless.wiki.kernel.org/en/users/drivers/ath5k
- DEPENDS+= @(PCI_SUPPORT||TARGET_ath25) +kmod-ath +@DRIVER_11W_SUPPORT
+ DEPENDS+= @PCI_SUPPORT +kmod-ath +@DRIVER_11W_SUPPORT
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath5k/ath5k.ko
AUTOLOAD:=$(call AutoProbe,ath5k)
endef