aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/ath.mk
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2019-09-18 19:58:49 +0200
committerDaniel Golle <daniel@makrotopia.org>2021-01-05 02:16:24 +0000
commit6442b8cbc2e4c53ffa4a6b7c30c2571dac87902d (patch)
treed27b9bea2e0765b415947a3a7a57bab98f955486 /package/kernel/mac80211/ath.mk
parent246fd27e522b10c173db24a8648cd57690f3435e (diff)
downloadupstream-6442b8cbc2e4c53ffa4a6b7c30c2571dac87902d.tar.gz
upstream-6442b8cbc2e4c53ffa4a6b7c30c2571dac87902d.tar.bz2
upstream-6442b8cbc2e4c53ffa4a6b7c30c2571dac87902d.zip
mac80211: Add wil6210 driver
This patch adds wil6210 driver for Wilocity/QCA based 802.11ad PCI cards. Driver uses cfg80211 and nl80211 but not mac80211. Integration for UCI and LuCI will come in other patches. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package/kernel/mac80211/ath.mk')
-rw-r--r--package/kernel/mac80211/ath.mk18
1 files changed, 15 insertions, 3 deletions
diff --git a/package/kernel/mac80211/ath.mk b/package/kernel/mac80211/ath.mk
index 957c9da939..24abb910ff 100644
--- a/package/kernel/mac80211/ath.mk
+++ b/package/kernel/mac80211/ath.mk
@@ -1,6 +1,6 @@
PKG_DRIVERS += \
ath ath5k ath6kl ath6kl-sdio ath6kl-usb ath9k ath9k-common ath9k-htc ath10k \
- carl9170 owl-loader ar5523
+ carl9170 owl-loader ar5523 wil6210
PKG_CONFIG_DEPENDS += \
CONFIG_PACKAGE_ATH_DEBUG \
@@ -21,7 +21,8 @@ ifdef CONFIG_PACKAGE_MAC80211_DEBUGFS
ATH10K_DEBUGFS \
CARL9170_DEBUGFS \
ATH5K_DEBUG \
- ATH6KL_DEBUG
+ ATH6KL_DEBUG \
+ WIL6210_DEBUGFS
endif
ifdef CONFIG_PACKAGE_MAC80211_TRACING
@@ -29,7 +30,8 @@ ifdef CONFIG_PACKAGE_MAC80211_TRACING
ATH10K_TRACING \
ATH6KL_TRACING \
ATH_TRACEPOINTS \
- ATH5K_TRACER
+ ATH5K_TRACER \
+ WIL6210_TRACING
endif
config-$(call config_package,ath) += ATH_CARDS ATH_COMMON ATH_REG_DYNAMIC_USER_REG_HINTS
@@ -68,6 +70,8 @@ config-$(call config_package,ath6kl-usb) += ATH6KL_USB
config-$(call config_package,carl9170) += CARL9170
config-$(call config_package,ar5523) += AR5523
+config-$(call config_package,wil6210) += WIL6210
+
define KernelPackage/ath/config
if PACKAGE_kmod-ath
config ATH_USER_REGD
@@ -309,3 +313,11 @@ define KernelPackage/ar5523
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ar5523/ar5523.ko
AUTOLOAD:=$(call AutoProbe,ar5523)
endef
+
+define KernelPackage/wil6210
+ $(call KernelPackage/mac80211/Default)
+ TITLE:=QCA/Wilocity 60g WiFi card wil6210 support
+ DEPENDS+= @PCI_SUPPORT +kmod-mac80211 +wil6210-firmware
+ FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/wil6210/wil6210.ko
+ AUTOLOAD:=$(call AutoProbe,wil6210)
+endef