aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-03-25 15:20:59 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-03 21:27:12 +0200
commitcd3b29853380676bb7e51283050c2044048f8f85 (patch)
tree254984a7195994f26fa3fd6b9c3a7c9b9182bf1e /package/kernel/mac80211/Makefile
parent8ba38cc1458bf0601704bcfd2b69939a7bd4cf06 (diff)
downloadupstream-cd3b29853380676bb7e51283050c2044048f8f85.tar.gz
upstream-cd3b29853380676bb7e51283050c2044048f8f85.tar.bz2
upstream-cd3b29853380676bb7e51283050c2044048f8f85.zip
omap24xx: Remove unmaintained target
This target only supports kernel 4.1, which is not supported in OpenWrt any more for multiple releases. It also looks like there is no active maintainer for this target. Remove the code and all the packages which are only used by this target. To add this target to OpenWrt again port it to a recent and supported kernel version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 5ab42f0a1f..30f6353b65 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -28,7 +28,7 @@ PKG_DRIVERS = \
lib80211 \
mac80211-hwsim \
mt7601u \
- p54-common p54-pci p54-spi p54-usb \
+ p54-common p54-pci p54-usb \
rsi91x rsi91x-usb rsi91x-sdio\
wlcore wl12xx wl18xx \
zd1211rw
@@ -275,7 +275,7 @@ endef
define KernelPackage/p54-common
$(call KernelPackage/p54/Default)
- DEPENDS+= @PCI_SUPPORT||@USB_SUPPORT||@TARGET_omap24xx +kmod-mac80211 +kmod-lib-crc-ccitt +@DRIVER_11W_SUPPORT
+ DEPENDS+= @PCI_SUPPORT||@USB_SUPPORT +kmod-mac80211 +kmod-lib-crc-ccitt +@DRIVER_11W_SUPPORT
TITLE+= (COMMON)
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/p54/p54common.ko
endef
@@ -296,14 +296,6 @@ define KernelPackage/p54-usb
AUTOLOAD:=$(call AutoProbe,p54usb)
endef
-define KernelPackage/p54-spi
- $(call KernelPackage/p54/Default)
- TITLE+= (SPI)
- DEPENDS+= @TARGET_omap24xx +kmod-p54-common +p54-spi-firmware
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/p54/p54spi.ko
- AUTOLOAD:=$(call AutoProbe,p54spi)
-endef
-
define KernelPackage/rsi91x
$(call KernelPackage/mac80211/Default)
TITLE:=Redpine Signals Inc 91x WLAN driver support
@@ -408,7 +400,6 @@ config-y += WL_MEDIATEK
config-$(call config_package,p54-common) += P54_COMMON
config-$(call config_package,p54-pci) += P54_PCI
config-$(call config_package,p54-usb) += P54_USB
-config-$(call config_package,p54-spi) += P54_SPI
config-$(call config_package,hermes) += HERMES
config-$(call config_package,hermes-pci) += PCI_HERMES