aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2021-03-08 15:28:51 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-19 01:25:26 +0100
commitb1d0f66388e67ecf0c8b0fdfee8e2bfda947d319 (patch)
treecd44f976456bf89ed6eef18d34e842eb6c93a783 /package/kernel/mac80211/Makefile
parenteccb45627ec62311d1c9cb18f02abef638a5291f (diff)
downloadupstream-b1d0f66388e67ecf0c8b0fdfee8e2bfda947d319.tar.gz
upstream-b1d0f66388e67ecf0c8b0fdfee8e2bfda947d319.tar.bz2
upstream-b1d0f66388e67ecf0c8b0fdfee8e2bfda947d319.zip
mac80211: rtl: update RTL8821AE PHY/RF parameters
Create a new directory for Realtek patches and backport the updated PHY and RF parameters patch. Improves the connectivity in the 5 GHz band [1]. [1] https://patchwork.kernel.org/project/linux-wireless/patch/20210219052607.7323-1-pkshih@realtek.com/#23988567 Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index f6ad06452f..b92df681cb 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -504,6 +504,7 @@ define Build/Patch
$(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/rt2x00,rt2x00/)
$(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/mwl,mwl/)
$(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/brcm,brcm/)
+ $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/rtl,rtl/)
$(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
endef
@@ -514,6 +515,7 @@ define Quilt/Refresh/Package
$(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/rt2x00,rt2x00/)
$(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/mwl,mwl/)
$(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/brcm,brcm/)
+ $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/rtl,rtl/)
endef
define Build/Compile