aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-10-31 12:36:55 +0100
committerFelix Fietkau <nbd@nbd.name>2019-11-05 12:09:36 +0100
commit8b15e7f661b4263a7b9fb6a410a5f58263b72caa (patch)
treed59c3a68ab5b2004cb42d6d2f77cc4dd51613f82 /package/kernel/mac80211/Makefile
parentd64daf7026ce47788f12130462a3107bdab8718f (diff)
downloadupstream-8b15e7f661b4263a7b9fb6a410a5f58263b72caa.tar.gz
upstream-8b15e7f661b4263a7b9fb6a410a5f58263b72caa.tar.bz2
upstream-8b15e7f661b4263a7b9fb6a410a5f58263b72caa.zip
mac80211: add support for multiple wiphys behind a single device
The device path will be the same for the first phy. For all subsequent phys, the path gets an extra +1, +2, ... Move the code for converting path to phy and vice versa to a separate library script shared by config detection code and the netifd wireless handler script Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 29363748ec..7e74182ef3 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -546,6 +546,7 @@ endef
define KernelPackage/cfg80211/install
$(INSTALL_DIR) $(1)/lib/wifi $(1)/lib/netifd/wireless
$(INSTALL_DATA) ./files/lib/wifi/mac80211.sh $(1)/lib/wifi
+ $(INSTALL_DATA) ./files/lib/netifd/mac80211.sh $(1)/lib/netifd
$(INSTALL_BIN) ./files/lib/netifd/wireless/mac80211.sh $(1)/lib/netifd/wireless
$(INSTALL_DIR) $(1)/etc/hotplug.d/ieee80211
$(INSTALL_DATA) ./files/mac80211.hotplug $(1)/etc/hotplug.d/ieee80211/10-wifi-detect