aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-06-15 14:57:14 +0200
committerJo-Philipp Wich <jo@mein.io>2019-06-20 14:16:08 +0200
commit74739c4228f3bd0aa757165c67c53016c3deb544 (patch)
tree6dc6ff0bb582a52f743f1da5dd0140a8d7e063f1 /package/kernel/mac80211/Makefile
parent75dcaf3d23301da35eb4a6d0efc5ba5a0ed09850 (diff)
downloadupstream-74739c4228f3bd0aa757165c67c53016c3deb544.tar.gz
upstream-74739c4228f3bd0aa757165c67c53016c3deb544.tar.bz2
upstream-74739c4228f3bd0aa757165c67c53016c3deb544.zip
treewide: fix syntax errors exposed after kconfig update
After commit e82a4d9cfb ("config: regenerate *_shipped sources") the mconf parser became more strict as a side effect and started to spew a series of warnings when evaluating our generated kconfig sources: tmp/.config-package.in:705:warning: ignoring unsupported character '@' The root cause of these warnings is a wrong use of the @SYMBOL dependency syntax in various Makefile. Fix the corresponding Makefiles by turning `@SYM||@SYM2` expressions into the proper `@(SYM||SYM2)` form. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 30f6353b65..20258fd662 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -275,7 +275,7 @@ endef
define KernelPackage/p54-common
$(call KernelPackage/p54/Default)
- DEPENDS+= @PCI_SUPPORT||@USB_SUPPORT +kmod-mac80211 +kmod-lib-crc-ccitt +@DRIVER_11W_SUPPORT
+ DEPENDS+= @(PCI_SUPPORT||USB_SUPPORT) +kmod-mac80211 +kmod-lib-crc-ccitt +@DRIVER_11W_SUPPORT
TITLE+= (COMMON)
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/intersil/p54/p54common.ko
endef