aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-02-03 21:15:42 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-02-26 14:38:24 +0800
commit5f5fae27b508a86599e93ac74c611e0dadf9105a (patch)
tree95635893b92a01cf55ffe63281db4366f783561f /package/kernel/mac80211/Makefile
parent2b22e1d5c3aa7740c94ea56dee6b91732b92e0c1 (diff)
downloadupstream-5f5fae27b508a86599e93ac74c611e0dadf9105a.tar.gz
upstream-5f5fae27b508a86599e93ac74c611e0dadf9105a.tar.bz2
upstream-5f5fae27b508a86599e93ac74c611e0dadf9105a.zip
mac80211: hwsim: select DRIVER_11AC_SUPPORT and DRIVER_11W_SUPPORT
This is required for default wireless configuration of malta target to work out of the box again. Fixes "77ece30e: hostapd: Add ability to specify that that wireless driver supports 802.11ac" Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 5a591e4b83..578014ffaa 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1022,7 +1022,7 @@ endef
define KernelPackage/mac80211-hwsim
$(call KernelPackage/mac80211/Default)
TITLE:=mac80211 HW simulation device
- DEPENDS+= +kmod-mac80211 +@DRIVER_11N_SUPPORT
+ DEPENDS+= +kmod-mac80211 +@DRIVER_11AC_SUPPORT +@DRIVER_11N_SUPPORT +@DRIVER_11W_SUPPORT
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/mac80211_hwsim.ko
AUTOLOAD:=$(call AutoProbe,mac80211_hwsim)
endef