aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2017-04-12 12:44:12 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2017-04-12 12:48:35 +0200
commit5ba8185866a8d9b2e963551737533eb6208e504b (patch)
treeeda088ac4ffd0a10600f57a01ef6758db02ddf4a /package/kernel/mac80211/Makefile
parent06997d2635f57ef455601e77301f7ab3320bc7a4 (diff)
downloadupstream-5ba8185866a8d9b2e963551737533eb6208e504b.tar.gz
upstream-5ba8185866a8d9b2e963551737533eb6208e504b.tar.bz2
upstream-5ba8185866a8d9b2e963551737533eb6208e504b.zip
mac80211: manually apply dependencies to prevent a recoursive one
Apply the !UML dependency to both the symbol and the DEPENDS so there is no recursive dependency anymore. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 545ecdd6f4..60efdaa9fc 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -687,7 +687,7 @@ define KernelPackage/brcmfmac
TITLE:=Broadcom IEEE802.11n USB FullMAC WLAN driver
URL:=https://wireless.wiki.kernel.org/en/users/drivers/brcm80211
DEPENDS+= @USB_SUPPORT +kmod-cfg80211 +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT +kmod-brcmutil \
- +BRCMFMAC_SDIO:kmod-mmc \
+ +BRCMFMAC_SDIO&&!TARGET_uml:kmod-mmc \
+BRCMFMAC_USB:kmod-usb-core +BRCMFMAC_USB:brcmfmac-firmware-usb
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko
AUTOLOAD:=$(call AutoProbe,brcmfmac)
@@ -702,6 +702,7 @@ define KernelPackage/brcmfmac/config
config BRCMFMAC_SDIO
bool "Enable SDIO bus interface support"
+ depends on !TARGET_uml
default y if TARGET_brcm2708
default n
help