aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-01-28 08:51:11 +0100
committerJohn Crispin <john@phrozen.org>2018-01-28 08:51:11 +0100
commitd4f539030bf5a0c6d1120af4aea2035536fa16f8 (patch)
tree16e1e5b1fc580001a4384ee2ca054c93e9d9e4a9 /package/kernel/linux
parent60ad837bea4a006a54fd8b659083f7bf648da781 (diff)
downloadupstream-d4f539030bf5a0c6d1120af4aea2035536fa16f8.tar.gz
upstream-d4f539030bf5a0c6d1120af4aea2035536fa16f8.tar.bz2
upstream-d4f539030bf5a0c6d1120af4aea2035536fa16f8.zip
Revert "netdevices.mk: add missing dependency to kmod-hwmon-core"
This reverts commit 53f62bc5e5c36c1a08e162d8b26de7d831fc36e5. commit made the builders fail with "Package kmod-igb is missing dependencies for the following libraries: hwmon.ko" Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netdevices.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index edc982d3c1..6b4c186dc6 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -519,7 +519,7 @@ $(eval $(call KernelPackage,e1000e))
define KernelPackage/igb
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Intel(R) 82575/82576 PCI-Express Gigabit Ethernet support
- DEPENDS:=@PCI_SUPPORT +kmod-i2c-core +kmod-i2c-algo-bit +kmod-ptp +kmod-hwmon-core
+ DEPENDS:=@PCI_SUPPORT +kmod-i2c-core +kmod-i2c-algo-bit +kmod-ptp
KCONFIG:=CONFIG_IGB \
CONFIG_IGB_HWMON=y \
CONFIG_IGB_DCA=n
@@ -555,7 +555,7 @@ $(eval $(call KernelPackage,igbvf))
define KernelPackage/ixgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Intel(R) 82598/82599 PCI-Express 10 Gigabit Ethernet support
- DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core
+ DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp
KCONFIG:=CONFIG_IXGBE \
CONFIG_IXGBE_VXLAN=n \
CONFIG_IXGBE_HWMON=y \