aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2021-02-20 17:44:12 +0100
committerChristian Lamparter <chunkeey@gmail.com>2021-03-05 22:47:14 +0100
commitbe23f9818a1dcb689cb28be39b497262b70d91cf (patch)
tree96779c142811f510f7011d6861ac869eb1ff0730 /package/kernel/linux
parentca14dfb06b09beb664318459241c948bd98c9332 (diff)
downloadupstream-be23f9818a1dcb689cb28be39b497262b70d91cf.tar.gz
upstream-be23f9818a1dcb689cb28be39b497262b70d91cf.tar.bz2
upstream-be23f9818a1dcb689cb28be39b497262b70d91cf.zip
apm821xx: add support for kernel 5.10 for testing
This patch copies over refreshed patches from 5.4. - dropped crypto patches (they got upstreamed) - dropped renesas USB 3 firmware loader (they got upstreamed) - NAND now needs extra device-properties for ECC settings. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/usb.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 9ef3fb5974..1f72d89512 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1653,6 +1653,11 @@ XHCI_MODULES := xhci-hcd xhci-pci xhci-plat-hcd
ifdef CONFIG_TARGET_ramips_mt7621
XHCI_MODULES += xhci-mtk
endif
+ifndef CONFIG_LINUX_5_4
+ ifdef CONFIG_TARGET_apm821xx_nand
+ XHCI_MODULES += xhci-pci-renesas
+ endif
+endif
XHCI_FILES := $(wildcard $(patsubst %,$(LINUX_DIR)/drivers/usb/host/%.ko,$(XHCI_MODULES)))
XHCI_AUTOLOAD := $(patsubst $(LINUX_DIR)/drivers/usb/host/%.ko,%,$(XHCI_FILES))
@@ -1667,6 +1672,7 @@ define KernelPackage/usb3
CONFIG_USB_XHCI_PCI \
CONFIG_USB_XHCI_PLATFORM \
CONFIG_USB_XHCI_MTK \
+ CONFIG_USB_XHCI_PCI_RENESAS \
CONFIG_USB_XHCI_HCD_DEBUGGING=n
FILES:= \
$(XHCI_FILES)