aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2020-04-12 17:45:41 +0300
committerPetr Štetiar <ynezz@true.cz>2020-07-08 16:07:05 +0200
commitb88f8202c4ced971de26268597d2e798ecdc0ba2 (patch)
tree8009086c7db803fb28ba57e72c5a24a17562a6d8 /package/kernel/linux
parent9f020269332d50dba61f5bce5f1d055b683b059e (diff)
downloadupstream-b88f8202c4ced971de26268597d2e798ecdc0ba2.tar.gz
upstream-b88f8202c4ced971de26268597d2e798ecdc0ba2.tar.bz2
upstream-b88f8202c4ced971de26268597d2e798ecdc0ba2.zip
kernel: add iscsi-initator support
Module is needed for using iscsi-initiator userspace applications Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com> [added missing newline between kernel modules] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/block.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index b870304ad4..a86c60da2a 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -270,6 +270,32 @@ endef
$(eval $(call KernelPackage,dm-raid))
+define KernelPackage/iscsi-initiator
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=iSCSI Initiator over TCP/IP
+ DEPENDS:=+kmod-scsi-core
+ KCONFIG:= \
+ CONFIG_INET \
+ CONFIG_SCSI_LOWLEVEL \
+ CONFIG_ISCSI_TCP \
+ CONFIG_SCSI_ISCSI_ATTRS
+ FILES:= \
+ $(LINUX_DIR)/drivers/scsi/iscsi_tcp.ko \
+ $(LINUX_DIR)/drivers/scsi/libiscsi.ko \
+ $(LINUX_DIR)/drivers/scsi/libiscsi_tcp.ko \
+ $(LINUX_DIR)/drivers/scsi/scsi_transport_iscsi.ko
+ AUTOLOAD:=$(call AutoProbe,libiscsi libiscsi_tcp scsi_transport_iscsi iscsi_tcp)
+endef
+
+define KernelPackage/iscsi-initiator/description
+The iSCSI Driver provides a host with the ability to access storage through an
+IP network. The driver uses the iSCSI protocol to transport SCSI requests and
+responses over a TCP/IP network between the host (the "initiator") and "targets".
+endef
+
+$(eval $(call KernelPackage,iscsi-initiator))
+
+
define KernelPackage/md-mod
SUBMENU:=$(BLOCK_MENU)
TITLE:=MD RAID