aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 12:42:41 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 12:42:41 +0000
commit8f100f4f2e1ee0689f5ba70341283c0a87932370 (patch)
treee92d9d7356bd02a4bc9cd4d4690148594a2672f2 /package/kernel/linux
parentdcf42b40fc79f35551cdd24da15ad1811c62bb64 (diff)
downloadupstream-8f100f4f2e1ee0689f5ba70341283c0a87932370.tar.gz
upstream-8f100f4f2e1ee0689f5ba70341283c0a87932370.tar.bz2
upstream-8f100f4f2e1ee0689f5ba70341283c0a87932370.zip
kernel: usb.mk: enable chipidea udc mode
The chipidea USB OTG controller is dual-role and supports both host and device modes. Enable device mode. Tested on Gateworks Ventana imx6 board with g_ether. Are there any other targets out there that use the CHIPIDEA controller? If so testing is needed for those. Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 40905
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/usb.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 096d55aa8e..e137515487 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1336,7 +1336,7 @@ define KernelPackage/usb-chipidea
KCONFIG:=\
CONFIG_USB_CHIPIDEA \
CONFIG_USB_CHIPIDEA_HOST=y \
- CONFIG_USB_CHIPIDEA_UDC=n \
+ CONFIG_USB_CHIPIDEA_UDC=y \
CONFIG_USB_CHIPIDEA_DEBUG=y
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.11.0)),1)
FILES:=\
@@ -1347,9 +1347,10 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.11.0)),1)
else
FILES:=\
$(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc.ko \
+ $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/gadget/udc-core.ko) \
$(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko) \
$(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko)
- AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imx),1)
+ AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imxudc-core),1)
endif
$(call AddDepends/usb)
endef