aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-04 12:53:57 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-04 12:53:57 +0000
commit80f958c88d76781169ea60daa899fc6664a218b4 (patch)
tree964599b384a8048534a759da4c81325f14861631 /package/kernel/linux
parent3c5e9dfcc93f0fa1cdad4fce18b14820c0d1c1d1 (diff)
downloadupstream-80f958c88d76781169ea60daa899fc6664a218b4.tar.gz
upstream-80f958c88d76781169ea60daa899fc6664a218b4.tar.bz2
upstream-80f958c88d76781169ea60daa899fc6664a218b4.zip
CC: kernel: kmod-scsi-core: fix load on install
sd_mod depends on scsi_mod, but due to it being an AutoLoad and not AutoProbe module, it was not loading when installing the package, causing unknown symbol errors for sd_mod and anything depending on it. Closes #14927, #18293, #19351. Backport of r46176. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46177 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/block.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 2d79e51021..2e75c71346 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -614,9 +614,9 @@ define KernelPackage/scsi-core
CONFIG_SCSI \
CONFIG_BLK_DEV_SD
FILES:= \
- $(if $(findstring y,$(CONFIG_SCSI)),,$(LINUX_DIR)/drivers/scsi/scsi_mod.ko) \
+ $(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
$(LINUX_DIR)/drivers/scsi/sd_mod.ko
- AUTOLOAD:=$(call AutoLoad,40,sd_mod,1)
+ AUTOLOAD:=$(call AutoLoad,40,scsi_mod sd_mod,1)
endef
$(eval $(call KernelPackage,scsi-core))