aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorKeith Wong <keithwky@gmail.com>2018-04-12 11:21:08 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-08-25 15:40:24 +0200
commit79c233daa4caee1a8af0c7a91e1d4aee96d410e9 (patch)
tree603f94b2762874b427be9cfa13ddd58120c6a2eb /package/kernel/linux
parente341f45913beac28e5574d470ed79e4b6f9ee255 (diff)
downloadupstream-79c233daa4caee1a8af0c7a91e1d4aee96d410e9.tar.gz
upstream-79c233daa4caee1a8af0c7a91e1d4aee96d410e9.tar.bz2
upstream-79c233daa4caee1a8af0c7a91e1d4aee96d410e9.zip
kernel: add kmod-tcp-bbr
This adds support for BBR (Bottleneck Bandwidth and RTT) TCP congestion control. Applications (e.g. webservers, VPN client/server) which initiate connections from router side can benefit from this. This provide an easier way for users to use BBR by selecting / installing kmod-tcp-bbr instead of altering kernel config and compiling firmware by themselves. Signed-off-by: Keith Wong <keithwky@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/files/sysctl-tcp-bbr-k4_9.conf5
-rw-r--r--package/kernel/linux/files/sysctl-tcp-bbr.conf4
-rw-r--r--package/kernel/linux/modules/netsupport.mk31
3 files changed, 40 insertions, 0 deletions
diff --git a/package/kernel/linux/files/sysctl-tcp-bbr-k4_9.conf b/package/kernel/linux/files/sysctl-tcp-bbr-k4_9.conf
new file mode 100644
index 0000000000..2f63b72888
--- /dev/null
+++ b/package/kernel/linux/files/sysctl-tcp-bbr-k4_9.conf
@@ -0,0 +1,5 @@
+# Do not edit, changes to this file will be lost on upgrades
+# /etc/sysctl.conf can be used to customize sysctl settings
+
+net.ipv4.tcp_congestion_control=bbr
+net.core.default_qdisc=fq
diff --git a/package/kernel/linux/files/sysctl-tcp-bbr.conf b/package/kernel/linux/files/sysctl-tcp-bbr.conf
new file mode 100644
index 0000000000..3a7dba2f0b
--- /dev/null
+++ b/package/kernel/linux/files/sysctl-tcp-bbr.conf
@@ -0,0 +1,4 @@
+# Do not edit, changes to this file will be lost on upgrades
+# /etc/sysctl.conf can be used to customize sysctl settings
+
+net.ipv4.tcp_congestion_control=bbr
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index ff76720636..050541488c 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -777,6 +777,37 @@ endef
$(eval $(call KernelPackage,sched))
+define KernelPackage/tcp-bbr
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=BBR TCP congestion control
+ DEPENDS:=@!LINUX_3_18 @!LINUX_4_1 @!LINUX_4_4 +LINUX_4_9:kmod-sched
+ KCONFIG:= \
+ CONFIG_TCP_CONG_ADVANCED=y \
+ CONFIG_TCP_CONG_BBR
+ FILES:=$(LINUX_DIR)/net/ipv4/tcp_bbr.ko
+ AUTOLOAD:=$(call AutoLoad,74,tcp_bbr)
+endef
+
+define KernelPackage/tcp-bbr/description
+ Kernel module for BBR (Bottleneck Bandwidth and RTT) TCP congestion
+ control. It requires the fq ("Fair Queue") pacing packet scheduler.
+ For kernel 4.13+, TCP internal pacing is implemented as fallback.
+endef
+
+ifdef CONFIG_LINUX_4_9
+ TCP_BBR_SYSCTL_CONF:=sysctl-tcp-bbr-k4_9.conf
+else
+ TCP_BBR_SYSCTL_CONF:=sysctl-tcp-bbr.conf
+endif
+
+define KernelPackage/tcp-bbr/install
+ $(INSTALL_DIR) $(1)/etc/sysctl.d
+ $(INSTALL_DATA) ./files/$(TCP_BBR_SYSCTL_CONF) $(1)/etc/sysctl.d/12-tcp-bbr.conf
+endef
+
+$(eval $(call KernelPackage,tcp-bbr))
+
+
define KernelPackage/ax25
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=AX25 support