aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 10:10:13 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 12:10:20 +0100
commit745069895775d1fbd8988a0825f24f6b503517b3 (patch)
tree763ad418aa3d04df53520a38f858b349db0689f8 /package/kernel/linux
parent7f0796d874f8cbcc1bd7705ff4edf8c30223d2bd (diff)
downloadupstream-745069895775d1fbd8988a0825f24f6b503517b3.tar.gz
upstream-745069895775d1fbd8988a0825f24f6b503517b3.tar.bz2
upstream-745069895775d1fbd8988a0825f24f6b503517b3.zip
imx6: enable the chipidea usb driver in the kernel config instead of packaging it
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/usb.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 3574bec5f7..7356602721 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1566,7 +1566,7 @@ $(eval $(call KernelPackage,usbip-server))
define KernelPackage/usb-chipidea-imx
TITLE:=Support for ChipIdea controllers
- DEPENDS:=@TARGET_imx6||TARGET_mxs +kmod-usb2 +USB_GADGET_SUPPORT:kmod-usb-gadget
+ DEPENDS:=@TARGET_mxs +kmod-usb2 +USB_GADGET_SUPPORT:kmod-usb-gadget
KCONFIG:=\
CONFIG_USB_CHIPIDEA \
CONFIG_USB_CHIPIDEA_HOST=y \
@@ -1589,7 +1589,7 @@ $(eval $(call KernelPackage,usb-chipidea-imx,1))
define KernelPackage/usb-mxs-phy
TITLE:=Support for Freescale MXS USB PHY
- DEPENDS:=@TARGET_imx6||TARGET_mxs +TARGET_mxs:kmod-usb-chipidea-imx
+ DEPENDS:=@TARGET_mxs +kmod-usb-chipidea-imx
KCONFIG:=CONFIG_USB_MXS_PHY
FILES:=\
$(LINUX_DIR)/drivers/usb/phy/phy-mxs-usb.ko