aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-06 04:18:10 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-06 04:42:00 +0000
commit20b6e014a61a9b40c30fab8184a9abd17f55085b (patch)
treef6dbd004ac3bc4760c2559a8ebdf8c1a13b9e7af /package/kernel/linux
parent2629d2d5b1efee1227df75d720be9dedcceb0e7b (diff)
downloadupstream-20b6e014a61a9b40c30fab8184a9abd17f55085b.tar.gz
upstream-20b6e014a61a9b40c30fab8184a9abd17f55085b.tar.bz2
upstream-20b6e014a61a9b40c30fab8184a9abd17f55085b.zip
kernel: fix kmod-usb3 on platforms without PCI
Partially restore the wild-card matching for kmod-usb3 modules to fix build on platforms without PCI which otherwise file, as seen on buildbot: ERROR: module '[...]/linux-5.4.102/drivers/usb/host/xhci-pci.ko' is missing. modules/usb.mk:1675: recipe for target '[...]/kmod-usb3_5.4.102-1_mips_mips32.ipk' failed Fixes: 7bda2e9aba ("kernel: fix kmod-usb3 dependencies") Fixes: be23f9818a ("apm821xx: add support for kernel 5.10") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/usb.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 1a45fb3670..3689f2d7c6 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1649,6 +1649,10 @@ endef
$(eval $(call KernelPackage,usbmon))
+XHCI_MODULES := xhci-pci xhci-plat-hcd
+XHCI_FILES := $(wildcard $(patsubst %,$(LINUX_DIR)/drivers/usb/host/%.ko,$(XHCI_MODULES)))
+XHCI_AUTOLOAD := $(patsubst $(LINUX_DIR)/drivers/usb/host/%.ko,%,$(XHCI_FILES))
+
define KernelPackage/usb3
TITLE:=Support for USB3 controllers
DEPENDS:= \
@@ -1662,9 +1666,8 @@ define KernelPackage/usb3
CONFIG_USB_XHCI_PCI \
CONFIG_USB_XHCI_PLATFORM
FILES:= \
- $(LINUX_DIR)/drivers/usb/host/xhci-pci.ko \
- $(LINUX_DIR)/drivers/usb/host/xhci-plat-hcd.ko
- AUTOLOAD:=$(call AutoLoad,54,xhci-pci xhci-plat-hcd,1)
+ $(XHCI_FILES)
+ AUTOLOAD:=$(call AutoLoad,54,$(XHCI_AUTOLOAD),1)
$(call AddDepends/usb)
endef