aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2020-07-08 22:49:57 +0300
committerPetr Štetiar <ynezz@true.cz>2020-07-09 10:28:40 +0200
commit1337093e87b42c06cd524a253d4081f186508e1d (patch)
tree05a73ed108095bb28916611c0b8d98c2135f5d4c /package/kernel/linux
parent36105880ee5749d85551934d36b42f7b1fc0a640 (diff)
downloadupstream-1337093e87b42c06cd524a253d4081f186508e1d.tar.gz
upstream-1337093e87b42c06cd524a253d4081f186508e1d.tar.bz2
upstream-1337093e87b42c06cd524a253d4081f186508e1d.zip
kernel: iscsi-initator: fix kernel config symbols
Enable SCSI low-level drivers on targets that don't have it already in order to fix following build failures on few platforms: .config:4739:warning: symbol value 'm' invalid for SCSI_LOWLEVEL * Restart config... * SCSI low-level drivers SCSI low-level drivers (SCSI_LOWLEVEL) [Y/n] (NEW) aborted! Fixes: b88f8202c4ce ("kernel: add iscsi-initator support") Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com> [commit subject and description facelift] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/block.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index faea5cc34e..fbd3c81911 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -276,9 +276,9 @@ define KernelPackage/iscsi-initiator
DEPENDS:=+kmod-scsi-core +kmod-crypto-hash
KCONFIG:= \
CONFIG_INET \
- CONFIG_SCSI_LOWLEVEL \
+ CONFIG_SCSI_LOWLEVEL=y \
CONFIG_ISCSI_TCP \
- CONFIG_SCSI_ISCSI_ATTRS
+ CONFIG_SCSI_ISCSI_ATTRS=y
FILES:= \
$(LINUX_DIR)/drivers/scsi/iscsi_tcp.ko \
$(LINUX_DIR)/drivers/scsi/libiscsi.ko \