aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2018-01-14 15:37:06 +0200
committerJohn Crispin <john@phrozen.org>2018-02-13 11:53:49 +0100
commit0b004ccec3912a9c36bbdd55bb1c4fd85d182547 (patch)
tree948a885d4a86e6e736ec1217cdcc870748369357 /package/kernel/linux
parentd1aae1a0547ffa3ea1ae865e0ad44a76288abda7 (diff)
downloadupstream-0b004ccec3912a9c36bbdd55bb1c4fd85d182547.tar.gz
upstream-0b004ccec3912a9c36bbdd55bb1c4fd85d182547.tar.bz2
upstream-0b004ccec3912a9c36bbdd55bb1c4fd85d182547.zip
can.mk: sort modules
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/can.mk191
1 files changed, 96 insertions, 95 deletions
diff --git a/package/kernel/linux/modules/can.mk b/package/kernel/linux/modules/can.mk
index 5529fe02e0..925de4d8a5 100644
--- a/package/kernel/linux/modules/can.mk
+++ b/package/kernel/linux/modules/can.mk
@@ -47,22 +47,6 @@ define AddDepends/can
endef
-define KernelPackage/can-raw
- TITLE:=Raw CAN Protcol
- KCONFIG:=CONFIG_CAN_RAW
- FILES:=$(LINUX_DIR)/net/can/can-raw.ko
- AUTOLOAD:=$(call AutoProbe,can-raw)
- $(call AddDepends/can)
-endef
-
-define KernelPackage/can-raw/description
- The raw CAN protocol option offers access to the CAN bus via
- the BSD socket API.
-endef
-
-$(eval $(call KernelPackage,can-raw))
-
-
define KernelPackage/can-bcm
TITLE:=Broadcast Manager CAN Protcol
KCONFIG:=CONFIG_CAN_BCM
@@ -80,6 +64,74 @@ endef
$(eval $(call KernelPackage,can-bcm))
+define KernelPackage/can-c-can
+ TITLE:=BOSCH C_CAN/D_CAN drivers
+ KCONFIG:=CONFIG_CAN_C_CAN
+ FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can.ko
+ AUTOLOAD:=$(call AutoProbe,c_can)
+ $(call AddDepends/can)
+endef
+
+define KernelPackage/can-c-can/description
+ This driver adds generic support for the C_CAN/D_CAN chips.
+endef
+
+$(eval $(call KernelPackage,can-c-can))
+
+
+define KernelPackage/can-c-can-pci
+ TITLE:=PCI Bus based BOSCH C_CAN/D_CAN driver
+ KCONFIG:=CONFIG_CAN_C_CAN_PCI
+ DEPENDS:=kmod-can-c-can @PCI_SUPPORT
+ FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_pci.ko
+ AUTOLOAD:=$(call AutoProbe,c_can_pci)
+ $(call AddDepends/can)
+endef
+
+define KernelPackage/can-c-can-pci/description
+ This driver adds support for the C_CAN/D_CAN chips connected
+ to the PCI bus.
+endef
+
+$(eval $(call KernelPackage,can-c-can-pci))
+
+
+define KernelPackage/can-c-can-platform
+ TITLE:=Platform Bus based BOSCH C_CAN/D_CAN driver
+ KCONFIG:=CONFIG_CAN_C_CAN_PLATFORM
+ DEPENDS:=kmod-can-c-can +!LINUX_3_18:kmod-regmap
+ FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_platform.ko
+ AUTOLOAD:=$(call AutoProbe,c_can_platform)
+ $(call AddDepends/can)
+endef
+
+define KernelPackage/can-c-can-platform/description
+ This driver adds support for the C_CAN/D_CAN chips connected
+ to the "platform bus" (Linux abstraction for directly to the
+ processor attached devices) which can be found on various
+ boards from ST Microelectronics (http://www.st.com) like the
+ SPEAr1310 and SPEAr320 evaluation boards & TI (www.ti.com)
+ boards like am335x, dm814x, dm813x and dm811x.
+endef
+
+$(eval $(call KernelPackage,can-c-can-platform))
+
+
+define KernelPackage/can-flexcan
+ TITLE:=Support for Freescale FLEXCAN based chips
+ KCONFIG:=CONFIG_CAN_FLEXCAN
+ FILES:=$(LINUX_DIR)/drivers/net/can/flexcan.ko
+ AUTOLOAD:=$(call AutoProbe,flexcan)
+ $(call AddDepends/can,@TARGET_imx6)
+endef
+
+define KernelPackage/can-flexcan/description
+ Freescale FLEXCAN CAN bus controller implementation.
+endef
+
+$(eval $(call KernelPackage,can-flexcan))
+
+
define KernelPackage/can-gw
TITLE:=CAN Gateway/Router
KCONFIG:=CONFIG_CAN_GW
@@ -95,20 +147,20 @@ endef
$(eval $(call KernelPackage,can-gw))
-define KernelPackage/can-vcan
- TITLE:=Virtual Local CAN Interface (vcan)
- KCONFIG:=CONFIG_CAN_VCAN
- FILES:=$(LINUX_DIR)/drivers/net/can/vcan.ko
- AUTOLOAD:=$(call AutoProbe,vcan)
+define KernelPackage/can-raw
+ TITLE:=Raw CAN Protcol
+ KCONFIG:=CONFIG_CAN_RAW
+ FILES:=$(LINUX_DIR)/net/can/can-raw.ko
+ AUTOLOAD:=$(call AutoProbe,can-raw)
$(call AddDepends/can)
endef
-define KernelPackage/can-vcan/description
- Similar to the network loopback devices, vcan offers a
- virtual local CAN interface.
+define KernelPackage/can-raw/description
+ The raw CAN protocol option offers access to the CAN bus via
+ the BSD socket API.
endef
-$(eval $(call KernelPackage,can-vcan))
+$(eval $(call KernelPackage,can-raw))
define KernelPackage/can-slcan
@@ -128,19 +180,20 @@ endef
$(eval $(call KernelPackage,can-slcan))
-define KernelPackage/can-flexcan
- TITLE:=Support for Freescale FLEXCAN based chips
- KCONFIG:=CONFIG_CAN_FLEXCAN
- FILES:=$(LINUX_DIR)/drivers/net/can/flexcan.ko
- AUTOLOAD:=$(call AutoProbe,flexcan)
- $(call AddDepends/can,@TARGET_imx6)
+define KernelPackage/can-usb-8dev
+ TITLE:=8 devices USB2CAN interface
+ KCONFIG:=CONFIG_CAN_8DEV_USB
+ FILES:=$(LINUX_DIR)/drivers/net/can/usb/usb_8dev.ko
+ AUTOLOAD:=$(call AutoProbe,usb_8dev)
+ $(call AddDepends/can,+kmod-usb-core)
endef
-define KernelPackage/can-flexcan/description
- Freescale FLEXCAN CAN bus controller implementation.
+define KernelPackage/can-usb-8dev/description
+ This driver supports the USB2CAN interface
+ from 8 devices (http://www.8devices.com).
endef
-$(eval $(call KernelPackage,can-flexcan))
+$(eval $(call KernelPackage,can-usb-8dev))
define KernelPackage/can-usb-ems
@@ -207,71 +260,19 @@ endef
$(eval $(call KernelPackage,can-usb-peak))
-define KernelPackage/can-usb-8dev
- TITLE:=8 devices USB2CAN interface
- KCONFIG:=CONFIG_CAN_8DEV_USB
- FILES:=$(LINUX_DIR)/drivers/net/can/usb/usb_8dev.ko
- AUTOLOAD:=$(call AutoProbe,usb_8dev)
- $(call AddDepends/can,+kmod-usb-core)
-endef
-
-define KernelPackage/can-usb-8dev/description
- This driver supports the USB2CAN interface
- from 8 devices (http://www.8devices.com).
-endef
-
-$(eval $(call KernelPackage,can-usb-8dev))
-
-
-define KernelPackage/can-c-can
- TITLE:=BOSCH C_CAN/D_CAN drivers
- KCONFIG:=CONFIG_CAN_C_CAN
- FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can.ko
- AUTOLOAD:=$(call AutoProbe,c_can)
- $(call AddDepends/can)
-endef
-
-define KernelPackage/can-c-can/description
- This driver adds generic support for the C_CAN/D_CAN chips.
-endef
-
-$(eval $(call KernelPackage,can-c-can))
-
-
-define KernelPackage/can-c-can-platform
- TITLE:=Platform Bus based BOSCH C_CAN/D_CAN driver
- KCONFIG:=CONFIG_CAN_C_CAN_PLATFORM
- DEPENDS:=kmod-can-c-can +!LINUX_3_18:kmod-regmap
- FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_platform.ko
- AUTOLOAD:=$(call AutoProbe,c_can_platform)
+define KernelPackage/can-vcan
+ TITLE:=Virtual Local CAN Interface (vcan)
+ KCONFIG:=CONFIG_CAN_VCAN
+ FILES:=$(LINUX_DIR)/drivers/net/can/vcan.ko
+ AUTOLOAD:=$(call AutoProbe,vcan)
$(call AddDepends/can)
endef
-define KernelPackage/can-c-can-platform/description
- This driver adds support for the C_CAN/D_CAN chips connected
- to the "platform bus" (Linux abstraction for directly to the
- processor attached devices) which can be found on various
- boards from ST Microelectronics (http://www.st.com) like the
- SPEAr1310 and SPEAr320 evaluation boards & TI (www.ti.com)
- boards like am335x, dm814x, dm813x and dm811x.
-endef
-
-$(eval $(call KernelPackage,can-c-can-platform))
-
-
-define KernelPackage/can-c-can-pci
- TITLE:=PCI Bus based BOSCH C_CAN/D_CAN driver
- KCONFIG:=CONFIG_CAN_C_CAN_PCI
- DEPENDS:=kmod-can-c-can @PCI_SUPPORT
- FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_pci.ko
- AUTOLOAD:=$(call AutoProbe,c_can_pci)
- $(call AddDepends/can)
+define KernelPackage/can-vcan/description
+ Similar to the network loopback devices, vcan offers a
+ virtual local CAN interface.
endef
-define KernelPackage/can-c-can-pci/description
- This driver adds support for the C_CAN/D_CAN chips connected
- to the PCI bus.
-endef
+$(eval $(call KernelPackage,can-vcan))
-$(eval $(call KernelPackage,can-c-can-pci))