aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2020-08-29 23:07:28 +0200
committerChristian Lamparter <chunkeey@gmail.com>2020-09-25 19:32:33 +0200
commitf6fbc397066e57d180aebc62e6bf52464d06bd76 (patch)
treeb720f3099775ad38c5a0487fad9b830e745521ce /package/kernel/linux/modules
parentfed1788689a180fa6f0ac2bc0f8f4659e8026e84 (diff)
downloadupstream-f6fbc397066e57d180aebc62e6bf52464d06bd76.tar.gz
upstream-f6fbc397066e57d180aebc62e6bf52464d06bd76.tar.bz2
upstream-f6fbc397066e57d180aebc62e6bf52464d06bd76.zip
build: define PWM_SUPPORT arch feature flag
As the PWM has its own sub-system in the Linux kernel, I think it should be handled in the same way as GPIO, RTC, PCI... This patch introduces a specific feature flag "pwm" and the "leds-pwm" kernel module as the first customer. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/leds.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/leds.mk b/package/kernel/linux/modules/leds.mk
index c030b54b39..fe90c6b559 100644
--- a/package/kernel/linux/modules/leds.mk
+++ b/package/kernel/linux/modules/leds.mk
@@ -159,3 +159,19 @@ define KernelPackage/leds-pca963x/description
endef
$(eval $(call KernelPackage,leds-pca963x))
+
+
+define KernelPackage/leds-pwm
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=PWM driven LED Support
+ KCONFIG:=CONFIG_LEDS_PWM
+ DEPENDS:= @PWM_SUPPORT
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-pwm.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-pwm,1)
+endef
+
+define KernelPackage/leds-pwm/description
+ This option enables support for pwm driven LEDs
+endef
+
+$(eval $(call KernelPackage,leds-pwm))