aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorAndreas Eberlein <foodeas@aeberlein.de>2020-06-23 22:59:26 +0200
committerPaul Spooren <mail@aparcar.org>2021-02-20 00:29:18 -1000
commita3e6521c1a7d4c78d825833e224272ec89a38bf2 (patch)
tree2bfbf9baf5438634193d3801642944bb3ac34697 /package/kernel/linux/modules
parent09e66112f1ea9f5838ce80533f3850523dc30230 (diff)
downloadupstream-a3e6521c1a7d4c78d825833e224272ec89a38bf2.tar.gz
upstream-a3e6521c1a7d4c78d825833e224272ec89a38bf2.tar.bz2
upstream-a3e6521c1a7d4c78d825833e224272ec89a38bf2.zip
x86: add led driver for PC Engines APU1
This driver adds the LED support for the PC Engines APU1. This integrates the Linux kernel driver and includes a patch to support newer firmware versions. Also the default LED configuration is updated to use the correct devices. Signed-off-by: Andreas Eberlein <foodeas@aeberlein.de>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/leds.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/leds.mk b/package/kernel/linux/modules/leds.mk
index bc94e54ae1..2e5a56df1a 100644
--- a/package/kernel/linux/modules/leds.mk
+++ b/package/kernel/linux/modules/leds.mk
@@ -84,6 +84,22 @@ endef
$(eval $(call KernelPackage,ledtrig-oneshot))
+define KernelPackage/leds-apu
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=PC Engines APU1 LED support
+ DEPENDS:= @GPIO_SUPPORT @TARGET_x86
+ KCONFIG:=CONFIG_LEDS_APU
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-apu.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-apu,1)
+endef
+
+define KernelPackage/leds-apu/description
+ Driver for the PC Engines APU1 LEDs.
+endef
+
+$(eval $(call KernelPackage,leds-apu))
+
+
define KernelPackage/leds-pca963x
SUBMENU:=$(LEDS_MENU)
TITLE:=PCA963x LED support