aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2021-01-04 17:59:30 +0100
committerPaul Spooren <mail@aparcar.org>2021-01-07 22:30:34 -1000
commit9919a1e7eacb894c14496c0a7fdb12f0c0e7cffa (patch)
treef958ed9da6ff6b75ea999e53700c360e5747b0b2 /package/kernel/linux/modules
parent211fed5f4930a26213281be67119c50e533c97a4 (diff)
downloadupstream-9919a1e7eacb894c14496c0a7fdb12f0c0e7cffa.tar.gz
upstream-9919a1e7eacb894c14496c0a7fdb12f0c0e7cffa.tar.bz2
upstream-9919a1e7eacb894c14496c0a7fdb12f0c0e7cffa.zip
kernel: add hid-cp2112 driver support
This patch adds kernel module for Silicon Labs CP2112 HID USB to SMBus Master Bridge. This is a HID device driver which registers as an i2c adapter and gpiochip to expose these functions of the CP2112. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/usb.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 81a7f00066..d050165df3 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1486,6 +1486,23 @@ endef
$(eval $(call KernelPackage,usb-hid))
+define KernelPackage/usb-hid-cp2112
+ SUBMENU:=$(USB_MENU)
+ TITLE:=Silicon Labs CP2112 HID USB to SMBus Master Bridge
+ KCONFIG:=CONFIG_GPIOLIB=y CONFIG_HID_CP2112
+ DEPENDS:=+kmod-usb-hid +kmod-i2c-core
+ FILES:=$(LINUX_DIR)/drivers/hid/hid-cp2112.ko
+ AUTOLOAD:=$(call AutoProbe,hid-cp2112)
+endef
+
+define KernelPackage/usb-hid-cp2112/description
+ HID device driver which registers as an i2c adapter and gpiochip to expose
+ these functions of the CP2112.
+endef
+
+$(eval $(call KernelPackage,usb-hid-cp2112))
+
+
define KernelPackage/usb-yealink
TITLE:=USB Yealink VOIP phone
DEPENDS:=+kmod-input-evdev