aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-03-07 20:22:03 -0800
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2021-03-14 17:52:49 +0000
commit95a3741d17b4cd7b9441187c356d449d0aa9d75d (patch)
tree3de6a15f9772fcb45a411690a8d53ec90bb0d7db /package/kernel/linux/modules
parent736edf9deaff3d5b866437c56f18dcb771b1ac09 (diff)
downloadupstream-95a3741d17b4cd7b9441187c356d449d0aa9d75d.tar.gz
upstream-95a3741d17b4cd7b9441187c356d449d0aa9d75d.tar.bz2
upstream-95a3741d17b4cd7b9441187c356d449d0aa9d75d.zip
kernel: support new mdio_devres.ko module in 5.10
Add kmod-mdio-devres package and kernel config symbol, and update related kmod-r8169 and kmod-ixgbe package dependencies. Build tested module dependencies on x86/64 with CONFIG_ALL_KMODS=y. Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/netdevices.mk24
1 files changed, 21 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 76675589fc..7d8bb34131 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -138,6 +138,23 @@ endef
$(eval $(call KernelPackage,mii))
+define KernelPackage/mdio-devres
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Supports MDIO device registration
+ DEPENDS:=@LINUX_5_10 +kmod-libphy
+ KCONFIG:=CONFIG_MDIO_DEVRES
+ HIDDEN:=1
+ FILES:=$(LINUX_DIR)/drivers/net/phy/mdio_devres.ko
+ AUTOLOAD:=$(call AutoProbe,mdio-devres)
+endef
+
+define KernelPackage/mdio-devres/description
+ Supports MDIO device registration
+endef
+
+$(eval $(call KernelPackage,mdio-devres))
+
+
define KernelPackage/mdio-gpio
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:= Supports GPIO lib-based MDIO busses
@@ -545,8 +562,9 @@ $(eval $(call KernelPackage,8139cp))
define KernelPackage/r8169
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support
- DEPENDS:=@PCI_SUPPORT +kmod-mii +r8169-firmware +kmod-phy-realtek
- KCONFIG:=CONFIG_R8169 \
+ DEPENDS:=@PCI_SUPPORT +kmod-mii +r8169-firmware +kmod-phy-realtek +LINUX_5_10:kmod-mdio-devres
+ KCONFIG:= \
+ CONFIG_R8169 \
CONFIG_R8169_NAPI=y \
CONFIG_R8169_VLAN=n
FILES:=$(LINUX_DIR)/drivers/net/ethernet/realtek/r8169.ko
@@ -670,7 +688,7 @@ $(eval $(call KernelPackage,igbvf))
define KernelPackage/ixgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Intel(R) 82598/82599 PCI-Express 10 Gigabit Ethernet support
- DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core +kmod-libphy
+ DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core +kmod-libphy +LINUX_5_10:kmod-mdio-devres
KCONFIG:=CONFIG_IXGBE \
CONFIG_IXGBE_VXLAN=n \
CONFIG_IXGBE_HWMON=y \