aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-10-14 23:03:25 -0700
committerPetr Štetiar <ynezz@true.cz>2020-12-22 18:59:10 +0100
commit57ad2a94211e68e418303d6ff2f70f03dfd4819a (patch)
tree05ed486e7cbaa55e232ff73b9a9aad9bfe53b06b /package/kernel/linux/modules
parent6e5759f6b4852515a6092a43a767a0f5e09a6cb7 (diff)
downloadupstream-57ad2a94211e68e418303d6ff2f70f03dfd4819a.tar.gz
upstream-57ad2a94211e68e418303d6ff2f70f03dfd4819a.tar.bz2
upstream-57ad2a94211e68e418303d6ff2f70f03dfd4819a.zip
fs/cifs: update module dependencies
0fdfef9aa7ee68ddd508aef7c98630cfc054f8d6 upstream removed CIFS_SMB311. Kernels 4.19 and above do not have it. Currently only kernels 4.19 and 5.4 are in the tree. The Kconfig file in the kernel has more selection that what is in here. Add the rest and reorder based on upstream ordering. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/fs.mk17
1 files changed, 10 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 18976a7941..d43542b17e 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -90,19 +90,22 @@ define KernelPackage/fs-cifs
KCONFIG:= \
CONFIG_CIFS \
CONFIG_CIFS_DFS_UPCALL=n \
- CONFIG_CIFS_UPCALL=n \
- CONFIG_CIFS_SMB311=n
+ CONFIG_CIFS_UPCALL=n
FILES:=$(LINUX_DIR)/fs/cifs/cifs.ko
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
DEPENDS+= \
- +kmod-crypto-arc4 \
- +kmod-crypto-hmac \
- +kmod-crypto-md5 \
+kmod-crypto-md4 \
- +kmod-crypto-des \
+ +kmod-crypto-md5 \
+ +kmod-crypto-sha256 \
+ +kmod-crypto-sha512 \
+ +kmod-crypto-cmac \
+ +kmod-crypto-hmac \
+ +kmod-crypto-arc4 \
+ +kmod-crypto-aead \
+ +kmod-crypto-ccm \
+kmod-crypto-ecb \
- +kmod-crypto-sha256
+ +kmod-crypto-des
endef
define KernelPackage/fs-cifs/description