aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/wireless.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-11-16 17:08:07 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-11-30 13:21:20 +0100
commit82a741c774dc1aa1e2c2e4b2e445bf79158de1a1 (patch)
tree04f0e6391a0c5967854abd0e2163397786546e23 /package/kernel/linux/modules/wireless.mk
parentf1410902e6c089a53935ab44e83207e877445bc5 (diff)
downloadupstream-82a741c774dc1aa1e2c2e4b2e445bf79158de1a1.tar.gz
upstream-82a741c774dc1aa1e2c2e4b2e445bf79158de1a1.tar.bz2
upstream-82a741c774dc1aa1e2c2e4b2e445bf79158de1a1.zip
mac80211: switch to upstream owl-loader driver
The Owl Loader (named after the codename that Atheros gave these devices back in the day) has been accepted upstream. This patch removes the "misc" driver OpenWrt had and adds the remaining differences against the version that ships with 5.4-rc1 into a separate "120-owl-loader-compat.patch" file that can be cut down once AR71XX is being dealt with. Note: I decided to keep the existing (kmod-)owl-loader package name around for now. The kernel module file in the kmod package will be called ath9k_pci_owl_loader.ko though. Acked-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/wireless.mk')
-rw-r--r--package/kernel/linux/modules/wireless.mk21
1 files changed, 0 insertions, 21 deletions
diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
index 7b1c663567..72e2bf477b 100644
--- a/package/kernel/linux/modules/wireless.mk
+++ b/package/kernel/linux/modules/wireless.mk
@@ -41,24 +41,3 @@ define KernelPackage/net-rtl8192su/description
endef
$(eval $(call KernelPackage,net-rtl8192su))
-
-
-define KernelPackage/owl-loader
- SUBMENU:=$(WIRELESS_MENU)
- TITLE:=Owl loader for initializing Atheros PCI(e) Wifi chips
- DEPENDS:=@PCI_SUPPORT
- KCONFIG:=CONFIG_OWL_LOADER
- FILES:=$(LINUX_DIR)/drivers/misc/owl-loader.ko
- AUTOLOAD:=$(call AutoProbe,owl-loader)
-endef
-
-define KernelPackage/owl-loader/description
- Kernel module that helps to initialize certain Qualcomm
- Atheros' PCI(e) Wifi chips, which have the init data
- (which contains the PCI device ID for example) stored
- together with the calibration data in the file system.
-
- This is necessary for devices like the Cisco Meraki Z1.
-endef
-
-$(eval $(call KernelPackage,owl-loader))