aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-08 14:21:22 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-08 14:25:07 +0100
commit36cccbb283092ef0c62b22d77abe3c0b0e0aea96 (patch)
tree91d5c206c1e0bc0b9caf1f9055d8821b949f2a30 /package/kernel/linux/modules/usb.mk
parent462a7c0e96d70ba82dfb5ddd41c82b66c3261ca2 (diff)
downloadupstream-36cccbb283092ef0c62b22d77abe3c0b0e0aea96.tar.gz
upstream-36cccbb283092ef0c62b22d77abe3c0b0e0aea96.tar.bz2
upstream-36cccbb283092ef0c62b22d77abe3c0b0e0aea96.zip
kernel: select kmod-phy-bcm-ns-usb* from kmod-usb* for bcm53xx
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 5f90e86ebc..3574bec5f7 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -464,6 +464,7 @@ define KernelPackage/usb2
+TARGET_brcm47xx:kmod-usb-bcma \
+TARGET_brcm47xx:kmod-usb-ssb \
+TARGET_bcm53xx:kmod-usb-bcma \
+ +TARGET_bcm53xx:kmod-phy-bcm-ns-usb2 \
+TARGET_mpc85xx:kmod-usb2-fsl
KCONFIG:=\
CONFIG_USB_EHCI_HCD \
@@ -1628,6 +1629,7 @@ define KernelPackage/usb3
TITLE:=Support for USB3 controllers
DEPENDS:= \
+TARGET_bcm53xx:kmod-usb-bcma \
+ +TARGET_bcm53xx:kmod-phy-bcm-ns-usb3 \
+TARGET_omap:kmod-usb-phy-omap-usb3
KCONFIG:= \
CONFIG_USB_XHCI_HCD \