aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-07-15 23:18:33 +0000
committerLuka Perkov <luka@openwrt.org>2013-07-15 23:18:33 +0000
commitb3ec189cdb19b20c0d020fc4bcdfaac0652e4114 (patch)
tree110896b4a3a21dc1ecd3f472034d23c14909c188 /package/kernel/linux/modules/sound.mk
parentdcd1741912176abaf7d98dbdbc9ac9b54bfce8d4 (diff)
downloadupstream-b3ec189cdb19b20c0d020fc4bcdfaac0652e4114.tar.gz
upstream-b3ec189cdb19b20c0d020fc4bcdfaac0652e4114.tar.bz2
upstream-b3ec189cdb19b20c0d020fc4bcdfaac0652e4114.zip
kernel: add sound-soc-imx
Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 37359
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk23
1 files changed, 22 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 494394603b..74de21f2ad 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -180,6 +180,27 @@ endef
$(eval $(call KernelPackage,sound-soc-ac97))
+define KernelPackage/sound-soc-imx
+ TITLE:=IMX SoC support
+ KCONFIG:=\
+ CONFIG_SND_IMX_SOC \
+ CONFIG_SND_SOC_IMX_AUDMUX \
+ CONFIG_SND_SOC_IMX_PCM
+ FILES:= \
+ $(LINUX_DIR)/sound/soc/fsl/snd-soc-imx-audmux.ko \
+ $(LINUX_DIR)/sound/soc/fsl/snd-soc-imx-pcm.ko
+ AUTOLOAD:=$(call AutoLoad,56,snd-soc-imx)
+ DEPENDS:=@TARGET_imx6 +kmod-sound-soc-core
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-imx/description
+ support for i.MX6 Platform sound (ssi/audmux/pcm)
+endef
+
+$(eval $(call KernelPackage,sound-soc-imx))
+
+
define KernelPackage/sound-soc-gw_avila
TITLE:=Gateworks Avila SoC sound support
KCONFIG:= \