aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-10-05 00:43:10 +0200
committerJo-Philipp Wich <jo@mein.io>2016-10-05 00:45:12 +0200
commit8462ec31345fdf9adde0faeb5096cb56d3165905 (patch)
tree97fdc9c56c558bd88477c38b7d5ac1f3135beb82 /package/kernel/linux/modules/sound.mk
parentc34676f4d4fc493a166e0ae7055d259bb925e695 (diff)
downloadupstream-8462ec31345fdf9adde0faeb5096cb56d3165905.tar.gz
upstream-8462ec31345fdf9adde0faeb5096cb56d3165905.tar.bz2
upstream-8462ec31345fdf9adde0faeb5096cb56d3165905.zip
kernel: add missing snd-hda-intel module for Linux 3.18 and 4.1
Prior to kernel 4.4, the hda-intel module depends on the hda-controller utility submodule so bundle it for the older kernel versions. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 13b0bb0dfe..2f3e79f55a 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -507,8 +507,9 @@ define KernelPackage/sound-hda-intel
CONFIG_SOUND_PCI \
CONFIG_SND_HDA_INTEL
FILES:= \
- $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko
- AUTOLOAD:=$(call AutoProbe,snd-hda-intel)
+ $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko \
+ $(LINUX_DIR)/sound/pci/hda/snd-hda-controller.ko@lt4.4
+ AUTOLOAD:=$(call AutoProbe,snd-hda-controller@lt4.4 snd-hda-intel)
$(call AddDepends/sound,kmod-sound-hda-core)
endef