aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-11-25 14:09:48 +0000
committerJohn Crispin <john@openwrt.org>2013-11-25 14:09:48 +0000
commit48de8ed52aa89fd7951cee067005b97440709863 (patch)
tree161dcf5a265bcaeba9409a4cb017ec6d43614939 /package/kernel/linux/modules/sound.mk
parent8a35c5936fa1aa56679d103e01ce62c0cadc900a (diff)
downloadupstream-48de8ed52aa89fd7951cee067005b97440709863.tar.gz
upstream-48de8ed52aa89fd7951cee067005b97440709863.tar.bz2
upstream-48de8ed52aa89fd7951cee067005b97440709863.zip
kernel/modules: snd-pcm-dmaengine only if CONFIG_SND_DMAENGINE_PCM is set
Platforms without in-soc audio don't provide CONFIG_SND_DMAENGINE_PCM, thus the module is not generated. SVN-Revision: 38913
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 4e1a656dd2..bed2e3c802 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -42,10 +42,10 @@ endif
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
SOUNDCORE_LOAD += \
- snd-pcm-dmaengine
+ $(if $(CONFIG_SND_DMAENGINE_PCM),snd-pcm-dmaengine)
SOUNDCORE_FILES += \
- $(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko
+ $(if $(CONFIG_SND_DMAENGINE_PCM),$(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko)
endif
define KernelPackage/sound-core