aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorDmitry Sutyagin <f3flight@gmail.com>2016-11-05 13:54:12 -0700
committerMathias Kresin <dev@kresin.me>2016-11-05 22:03:42 +0100
commit2ab6aaca4dfe1265006dae3f3cd0fd838f9bf2af (patch)
treea57e87959e85a98d5d3ffc1dd5445b677f09f83f /package/kernel/linux/modules/sound.mk
parent95ac6906aa8a254c69375fc093f69fd15c76189b (diff)
downloadupstream-2ab6aaca4dfe1265006dae3f3cd0fd838f9bf2af.tar.gz
upstream-2ab6aaca4dfe1265006dae3f3cd0fd838f9bf2af.tar.bz2
upstream-2ab6aaca4dfe1265006dae3f3cd0fd838f9bf2af.zip
kernel: add SND_PCM_TIMER to kmod-sound-core
FS#256 Fix audio not working due to unset SND_PCM_TIMER. CONFIG_SND_PCM_TIMER is required for ALSA to work (at least for some audio devices), otherwise applications using sound may fail. Can be reproduced by installing "alsa-utils-tests" and running "speaker-test": ... ALSA lib pcm_direct.c:1159:(snd1_pcm_direct_initialize_poll_fd) unable to open timer 'hw:CLASS=3,SCLASS=0,CARD=0,DEV=0,SUBDEV=0' ALSA lib pcm_dmix.c:1106:(snd_pcm_dmix_open) unable to initialize poll_fd Playback open error: -19,No such device The kernel size does not increase, only the size of the kernel module increases. Signed-off-by: Dmitry Sutyagin <f3flight@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 1a2d4f6d32..71765ed293 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -49,6 +49,7 @@ define KernelPackage/sound-core
CONFIG_SND_RAWMIDI \
CONFIG_SND_TIMER \
CONFIG_SND_PCM \
+ CONFIG_SND_PCM_TIMER \
CONFIG_SND_SEQUENCER \
CONFIG_SND_VIRMIDI \
CONFIG_SND_SEQ_DUMMY \