aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-05 13:57:48 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-08 16:45:08 +0100
commit28fd4ac512ec1c08a79ac7a434b2def3cc82f1d5 (patch)
tree1eebacbe18cd45507692a84388267837d0547ca1 /package/kernel/linux/modules/sound.mk
parent89f2deb372b74f9d4bb030c31b4ec28d579ee41f (diff)
downloadupstream-28fd4ac512ec1c08a79ac7a434b2def3cc82f1d5.tar.gz
upstream-28fd4ac512ec1c08a79ac7a434b2def3cc82f1d5.tar.bz2
upstream-28fd4ac512ec1c08a79ac7a434b2def3cc82f1d5.zip
ixp4xx: remove unmaintained target
This target is still on kernel 4.9, and it looks like there is no active maintainer for this target anymore. Remove the code and all the packages which are only used by this target. To add this target to OpenWrt again port it to a recent and supported kernel version. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk19
1 files changed, 0 insertions, 19 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index c83e553d8f..aa7eb72756 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -255,25 +255,6 @@ endef
$(eval $(call KernelPackage,sound-soc-imx-sgtl5000))
-define KernelPackage/sound-soc-gw_avila
- TITLE:=Gateworks Avila SoC sound support
- KCONFIG:= \
- CONFIG_SND_GW_AVILA_SOC \
- CONFIG_SND_GW_AVILA_SOC_PCM \
- CONFIG_SND_GW_AVILA_SOC_HSS
- FILES:= \
- $(LINUX_DIR)/sound/soc/codecs/snd-soc-tlv320aic3x.ko \
- $(LINUX_DIR)/sound/soc/gw-avila/snd-soc-gw-avila.ko \
- $(LINUX_DIR)/sound/soc/gw-avila/snd-soc-gw-avila-pcm.ko \
- $(LINUX_DIR)/sound/soc/gw-avila/snd-soc-gw-avila-hss.ko
- AUTOLOAD:=$(call AutoLoad,65,snd-soc-tlv320aic3x snd-soc-gw-avila snd-soc-gw-avila-pcm snd-soc-gw-avila-hss)
- DEPENDS:=@TARGET_ixp4xx +kmod-sound-soc-core
- $(call AddDepends/sound)
-endef
-
-$(eval $(call KernelPackage,sound-soc-gw_avila))
-
-
define KernelPackage/pcspkr
DEPENDS:=@TARGET_x86 +kmod-input-core
TITLE:=PC speaker support