aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-11-03 00:29:51 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-12-15 14:28:49 +0100
commitedc4da5da1719c04c9d5d0ae0bebf06c0631778f (patch)
treefb2558d1e0825f6fb676f612c7c6a9f0bea4edb2 /package/kernel/linux/modules/other.mk
parentc8f85a866b3796161260e85735e03729eb5886a0 (diff)
downloadupstream-edc4da5da1719c04c9d5d0ae0bebf06c0631778f.tar.gz
upstream-edc4da5da1719c04c9d5d0ae0bebf06c0631778f.tar.bz2
upstream-edc4da5da1719c04c9d5d0ae0bebf06c0631778f.zip
kernel: Always activate CONFIG_HW_RANDOM_TPM
CONFIG_HW_RANDOM_TPM does not activate a separate kernel module any more, but it only activates the random code in the tpm.ko. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 68e9366b5c..2fdb704556 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -900,7 +900,7 @@ define KernelPackage/random-tpm
TITLE:=Hardware Random Number Generator TPM support
KCONFIG:=CONFIG_HW_RANDOM_TPM
FILES:=$(LINUX_DIR)/drivers/char/hw_random/tpm-rng.ko
- DEPENDS:= +kmod-random-core +kmod-tpm
+ DEPENDS:= +kmod-random-core +kmod-tpm @!LINUX_4_19
AUTOLOAD:=$(call AutoProbe,tpm-rng)
endef