aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-11 10:43:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-11 10:43:46 +0000
commite8126cbfbd794cd25b12ede86ebc4108f304e979 (patch)
treec0289eba079966535ca67821115abaaf4cfddbdb /package/kernel/linux/modules/other.mk
parentf4af7fe1343f92e0342761c23eb5fe5f0dd63bc9 (diff)
downloadupstream-e8126cbfbd794cd25b12ede86ebc4108f304e979.tar.gz
upstream-e8126cbfbd794cd25b12ede86ebc4108f304e979.tar.bz2
upstream-e8126cbfbd794cd25b12ede86ebc4108f304e979.zip
kernel: remove kernel module checks/dependencies for 3.14
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45377
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 4696f2daec..bfdda2c389 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -70,7 +70,7 @@ $(eval $(call KernelPackage,bluetooth))
define KernelPackage/bluetooth_6lowpan
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth 6LoWPAN support
- DEPENDS:=+kmod-bluetooth @!LINUX_3_14
+ DEPENDS:=+kmod-bluetooth
KCONFIG:= \
CONFIG_6LOWPAN=m \
CONFIG_BT_6LOWPAN=m
@@ -739,7 +739,7 @@ $(eval $(call KernelPackage,ikconfig))
define KernelPackage/zram
SUBMENU:=$(OTHER_MENU)
TITLE:=ZRAM
- DEPENDS:=+kmod-lib-lzo +!LINUX_3_14:kmod-lib-lz4
+ DEPENDS:=+kmod-lib-lzo +kmod-lib-lz4
KCONFIG:= \
CONFIG_ZSMALLOC \
CONFIG_ZRAM \
@@ -966,8 +966,7 @@ define KernelPackage/echo
SUBMENU:=$(OTHER_MENU)
TITLE:=Line Echo Canceller
KCONFIG:=CONFIG_ECHO
- FILES:=$(LINUX_DIR)/drivers/staging/echo/echo.ko@lt3.18 \
- $(LINUX_DIR)/drivers/misc/echo/echo.ko@ge3.18
+ FILES:=$(LINUX_DIR)/drivers/misc/echo/echo.ko
AUTOLOAD:=$(call AutoLoad,50,echo)
endef