aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-10-31 22:02:07 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-10-31 22:02:07 +0000
commit7996f0b3135b1469823a15489d1a86804915ee5c (patch)
tree179cd5f5da311835fe8ea0dc9d1322f32981f251 /package/kernel/linux/modules/other.mk
parent26e68b353f0137aa08d2bbc18c33e011dfa3a571 (diff)
downloadupstream-7996f0b3135b1469823a15489d1a86804915ee5c.tar.gz
upstream-7996f0b3135b1469823a15489d1a86804915ee5c.tar.bz2
upstream-7996f0b3135b1469823a15489d1a86804915ee5c.zip
packages: kernel: negate kernel version checks
Only list the kernel versions that do not match so that new kernel versions will automatically match. This improves support for kernel 3.18. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 43132
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index c514fd7366..2f9831b16c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -13,7 +13,7 @@ WATCHDOG_DIR:=watchdog
define KernelPackage/6lowpan-iphc
USBMENU:=$(OTHER_MENU)
TITLE:=6lowpan shared code
- DEPENDS:=@LINUX_3_14
+ DEPENDS:=@!LINUX_3_3 @!LINUX_3_8 @!LINUX_3_10 @!LINUX_3_13
KCONFIG:=CONFIG_6LOWPAN_IPHC
HIDDEN:=1
FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan_iphc.ko
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +LINUX_3_14:kmod-6lowpan-iphc
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +(!LINUX_3_3&&!LINUX_3_8&&!LINUX_3_10&&!LINUX_3_13):kmod-6lowpan-iphc
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \