aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorDaniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>2018-01-18 03:52:12 -0800
committerJohn Crispin <john@phrozen.org>2018-01-22 07:17:11 +0100
commit666e9cf2220b11ccd024cad13ad54ca71d40c5b3 (patch)
tree14dde3e152af5d26d3b682f01ae2f87790144de7 /package/kernel/linux/modules/other.mk
parent36f1978a701cc76b2cd2e4c73ce5f2d5d68c4c51 (diff)
downloadupstream-666e9cf2220b11ccd024cad13ad54ca71d40c5b3.tar.gz
upstream-666e9cf2220b11ccd024cad13ad54ca71d40c5b3.tar.bz2
upstream-666e9cf2220b11ccd024cad13ad54ca71d40c5b3.zip
kernel: add IEEE-1284 parallel port support
The kmod-lp package included both lp.ko and ppdev.ko, but ECP device drivers may or may not require lp NOT to be loaded, needing only ppdev. Additionally, There were no packages for any parport interface modules, such as uss720 or parport_pc, provided here. It has not been otherwise possible to use PC-style parport hardware for kmod-lp. Signed-off-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk43
1 files changed, 38 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 973e4f3e26..94f98fffc9 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -285,18 +285,51 @@ endef
$(eval $(call KernelPackage,gpio-pcf857x))
-define KernelPackage/lp
+define KernelPackage/ppdev
SUBMENU:=$(OTHER_MENU)
- TITLE:=Parallel port and line printer support
+ TITLE:=Parallel port support
KCONFIG:= \
CONFIG_PARPORT \
- CONFIG_PRINTER \
CONFIG_PPDEV
FILES:= \
$(LINUX_DIR)/drivers/parport/parport.ko \
- $(LINUX_DIR)/drivers/char/lp.ko \
$(LINUX_DIR)/drivers/char/ppdev.ko
- AUTOLOAD:=$(call AutoLoad,50,parport lp ppdev)
+ AUTOLOAD:=$(call AutoLoad,50,parport ppdev)
+endef
+
+$(eval $(call KernelPackage,ppdev))
+
+
+define KernelPackage/parport-pc
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Parallel port interface (PC-style) support
+ DEPENDS:=+kmod-ppdev
+ KCONFIG:= \
+ CONFIG_PARPORT_PC \
+ CONFIG_PARPORT_1284=y \
+ CONFIG_PARPORT_PC_FIFO=y \
+ CONFIG_PARPORT_PC_SUPERIO=y \
+ CONFIG_PARPORT_SERIAL=n \
+ CONFIG_PARIDE=n \
+ CONFIG_SCSI_IMM=n \
+ CONFIG_SCSI_PPA=n
+ FILES:= \
+ $(LINUX_DIR)/drivers/parport/parport_pc.ko
+ AUTOLOAD:=$(call AutoLoad,51,parport_pc)
+endef
+
+$(eval $(call KernelPackage,parport-pc))
+
+
+define KernelPackage/lp
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Parallel port line printer device support
+ DEPENDS:=+kmod-ppdev
+ KCONFIG:= \
+ CONFIG_PRINTER
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/lp.ko
+ AUTOLOAD:=$(call AutoLoad,52,lp)
endef
$(eval $(call KernelPackage,lp))