aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:31 +0000
commit0b39a6d4e95c1969550eea89238a2f7c34433be2 (patch)
tree1e506740009c1b3453ec7af70cbfc00a70fa24e4 /package/kernel/linux/modules/other.mk
parentb2f3e852d0e42ee29f38c15033fadb736383bae1 (diff)
downloadupstream-0b39a6d4e95c1969550eea89238a2f7c34433be2.tar.gz
upstream-0b39a6d4e95c1969550eea89238a2f7c34433be2.tar.bz2
upstream-0b39a6d4e95c1969550eea89238a2f7c34433be2.zip
kernel: remove useless AddDepends/hid abstraction
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45134
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 1644f77ce4..c270481932 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16 +kmod-hid
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -50,7 +50,6 @@ define KernelPackage/bluetooth
CONFIG_BT_HCIUART_H4 \
CONFIG_BT_HIDP \
CONFIG_HID_SUPPORT=y
- $(call AddDepends/hid)
$(call AddDepends/rfkill)
FILES:= \
$(LINUX_DIR)/net/bluetooth/bluetooth.ko \