aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/lib.mk
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2020-06-25 15:20:23 +0100
committerPetr Štetiar <ynezz@true.cz>2020-07-11 13:33:28 +0200
commit99dae00fa86203effc3e7e41cbc8d89b9518848c (patch)
tree8d0de79fe03f94527dc6f43ff8e83636fce441f7 /package/kernel/linux/modules/lib.mk
parent0b6155de0ba0aa9e6942522ec6666c56a2f5aff1 (diff)
downloadupstream-99dae00fa86203effc3e7e41cbc8d89b9518848c.tar.gz
upstream-99dae00fa86203effc3e7e41cbc8d89b9518848c.tar.bz2
upstream-99dae00fa86203effc3e7e41cbc8d89b9518848c.zip
kernel: kmod-zram: break the strict dependency from lz4
Zram is only strictly dependent on lzo, not lz4. Break this dependency and make the lz4 module visible in the configuration, in order for the user to have the choice of enabling/disabling it, if (s)he sees fit. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/lib.mk')
-rw-r--r--package/kernel/linux/modules/lib.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index e14c6b31c0..1289cc1f25 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -147,7 +147,6 @@ define KernelPackage/lib-lz4
SUBMENU:=$(LIB_MENU)
TITLE:=LZ4 support
DEPENDS:=+kmod-crypto-acompress
- HIDDEN:=1
KCONFIG:= \
CONFIG_CRYPTO_LZ4 \
CONFIG_LZ4_COMPRESS \