aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:31 +0000
commit0b39a6d4e95c1969550eea89238a2f7c34433be2 (patch)
tree1e506740009c1b3453ec7af70cbfc00a70fa24e4 /package/kernel/linux/modules/input.mk
parentb2f3e852d0e42ee29f38c15033fadb736383bae1 (diff)
downloadupstream-0b39a6d4e95c1969550eea89238a2f7c34433be2.tar.gz
upstream-0b39a6d4e95c1969550eea89238a2f7c34433be2.tar.bz2
upstream-0b39a6d4e95c1969550eea89238a2f7c34433be2.zip
kernel: remove useless AddDepends/hid abstraction
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45134
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 2320b051f9..1e8b2f0257 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -25,10 +25,10 @@ $(eval $(call KernelPackage,hid))
define KernelPackage/hid-generic
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=Generic HID device support
+ DEPENDS:=+kmod-hid
KCONFIG:=CONFIG_HID_GENERIC
FILES:=$(LINUX_DIR)/drivers/hid/hid-generic.ko
AUTOLOAD:=$(call AutoProbe,hid-generic)
- $(call AddDepends/hid)
endef
define KernelPackage/hid/description