aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/i2c.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-16 14:55:40 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-16 16:26:29 +0100
commit6508766d24dd391880658ab5fe70385b3b37e286 (patch)
treef225fe185d176144839cde4371c5f3d7046f4617 /package/kernel/linux/modules/i2c.mk
parent8adcfe289ce5328ee1ff62fcfc8b244012738c50 (diff)
downloadupstream-6508766d24dd391880658ab5fe70385b3b37e286.tar.gz
upstream-6508766d24dd391880658ab5fe70385b3b37e286.tar.bz2
upstream-6508766d24dd391880658ab5fe70385b3b37e286.zip
kernel: make kmod-i2c-mux selected by dependent modules
Currently kmod-i2c-mux-* will not get into images unless kmod-i2c-mux is added to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to "select", we do not have the issue anymore. Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES and similar variables, as it is now pulled by dependent modules such as: - kmod-i2c-mux-pca954x Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'package/kernel/linux/modules/i2c.mk')
-rw-r--r--package/kernel/linux/modules/i2c.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index 90eee8b8f5..6690384a89 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -147,7 +147,7 @@ I2C_MUX_GPIO_MODULES:= \
define KernelPackage/i2c-mux-gpio
$(call i2c_defaults,$(I2C_MUX_GPIO_MODULES),51)
TITLE:=GPIO-based I2C mux/switches
- DEPENDS:=kmod-i2c-mux
+ DEPENDS:=+kmod-i2c-mux
endef
define KernelPackage/i2c-mux-gpio/description
@@ -163,7 +163,7 @@ I2C_MUX_PCA9541_MODULES:= \
define KernelPackage/i2c-mux-pca9541
$(call i2c_defaults,$(I2C_MUX_PCA9541_MODULES),51)
TITLE:=Philips PCA9541 I2C mux/switches
- DEPENDS:=kmod-i2c-mux
+ DEPENDS:=+kmod-i2c-mux
endef
define KernelPackage/i2c-mux-pca9541/description
@@ -178,7 +178,7 @@ I2C_MUX_PCA954x_MODULES:= \
define KernelPackage/i2c-mux-pca954x
$(call i2c_defaults,$(I2C_MUX_PCA954x_MODULES),51)
TITLE:=Philips PCA954x I2C mux/switches
- DEPENDS:=kmod-i2c-mux
+ DEPENDS:=+kmod-i2c-mux
endef
define KernelPackage/i2c-mux-pca954x/description