aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorRoman Bazalevsky <rvb@rvb.name>2018-11-05 06:16:44 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2018-11-25 19:26:56 +0100
commit1f4f9b2116e2cd74f964fdbb998928229c935d61 (patch)
treef1a5c7cd47fdc48ac6d222a0d2c434c4d7463967 /package/kernel/linux/modules/hwmon.mk
parente26a55e7499c1601c5285f3e1be4da76e739f53d (diff)
downloadupstream-1f4f9b2116e2cd74f964fdbb998928229c935d61.tar.gz
upstream-1f4f9b2116e2cd74f964fdbb998928229c935d61.tar.bz2
upstream-1f4f9b2116e2cd74f964fdbb998928229c935d61.zip
kernel/modules: TI ADS1015 kernel module support enabled.
Signed-off-by: Roman Bazalevsky <rvb@rvb.name>
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 5cd849b86d..00bb18501a 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -29,6 +29,20 @@ define AddDepends/hwmon
DEPENDS:=kmod-hwmon-core $(1)
endef
+define KernelPackage/hwmon-ads1015
+ TITLE:=Texas Instruments ADS1015
+ KCONFIG:= CONFIG_SENSORS_ADS1015
+ FILES:= $(LINUX_DIR)/drivers/hwmon/ads1015.ko
+ AUTOLOAD:=$(call AutoLoad,60,ads1015)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-ads1015/description
+ Kernel module for Texas Instruments ADS1015 Analog-to-Digital converter
+endef
+
+$(eval $(call KernelPackage,hwmon-ads1015))
+
define KernelPackage/hwmon-adt7410
TITLE:=ADT7410 monitoring support
KCONFIG:= \