aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 12:55:27 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 13:44:25 +0100
commit5b92dca09fb0414775c75f51b3ce8c99ad63292f (patch)
tree5765c39ec48c593fcce6d30c39d3e28c349dded8 /package/kernel/linux/modules/crypto.mk
parent9cdf852ae09e8b418d9ab5c462b95742dc2f0fc2 (diff)
downloadupstream-5b92dca09fb0414775c75f51b3ce8c99ad63292f.tar.gz
upstream-5b92dca09fb0414775c75f51b3ce8c99ad63292f.tar.bz2
upstream-5b92dca09fb0414775c75f51b3ce8c99ad63292f.zip
kernel: drop crypto-hw-ppc4xx
If any of the ppc4xx targets are restored, this should be built into the kernel instead Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 0f8305285d..abbd5afd66 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -240,24 +240,6 @@ endef
$(eval $(call KernelPackage,crypto-hw-hifn-795x))
-define KernelPackage/crypto-hw-ppc4xx
- TITLE:=AMCC PPC4xx hardware crypto module
- DEPENDS:=@TARGET_ppc40x||TARGET_ppc44x
- KCONFIG:= \
- CONFIG_CRYPTO_HW=y \
- CONFIG_CRYPTO_DEV_PPC4XX
- FILES:=$(LINUX_DIR)/drivers/crypto/amcc/crypto4xx.ko
- AUTOLOAD:=$(call AutoLoad,90,crypto4xx)
- $(call AddDepends/crypto,+kmod-crypto-manager +kmod-crypto-hash)
-endef
-
-define KernelPackage/crypto-hw-ppc4xx/description
- Kernel support for the AMCC PPC4xx HW crypto engine.
-endef
-
-$(eval $(call KernelPackage,crypto-hw-ppc4xx))
-
-
define KernelPackage/crypto-hw-omap
TITLE:=TI OMAP hardware crypto modules
DEPENDS:=@TARGET_omap