aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2019-11-06 18:22:51 -0300
committerDaniel Golle <daniel@makrotopia.org>2019-11-06 23:27:20 +0100
commit3540a37a973671b83a262d576464698c0d042e83 (patch)
tree7b25f4897f5c307565b1af346feeb811efa340cf /package/kernel/linux/modules/crypto.mk
parentf4853f7cca816214cd6e64cffe2b73d0b8c16def (diff)
downloadupstream-3540a37a973671b83a262d576464698c0d042e83.tar.gz
upstream-3540a37a973671b83a262d576464698c0d042e83.tar.bz2
upstream-3540a37a973671b83a262d576464698c0d042e83.zip
kernel: add crypto_user mod to crypto-user pkg
This is needed to export crypto information to netfilter, allowing the alt. afalg openssl engine to obtain information about the drivers being used. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index dc7eb77986..9e647eb18f 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -768,6 +768,7 @@ define KernelPackage/crypto-user
TITLE:=CryptoAPI userspace interface
DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
KCONFIG:= \
+ CONFIG_CRYPTO_USER \
CONFIG_CRYPTO_USER_API \
CONFIG_CRYPTO_USER_API_AEAD \
CONFIG_CRYPTO_USER_API_HASH \
@@ -778,8 +779,9 @@ define KernelPackage/crypto-user
$(LINUX_DIR)/crypto/algif_aead.ko \
$(LINUX_DIR)/crypto/algif_hash.ko \
$(LINUX_DIR)/crypto/algif_rng.ko \
- $(LINUX_DIR)/crypto/algif_skcipher.ko
- AUTOLOAD:=$(call AutoLoad,09,af_alg algif_aead algif_hash algif_rng algif_skcipher)
+ $(LINUX_DIR)/crypto/algif_skcipher.ko \
+ $(LINUX_DIR)/crypto/crypto_user.ko
+ AUTOLOAD:=$(call AutoLoad,09,af_alg algif_aead algif_hash algif_rng algif_skcipher crypto_user)
$(call AddDepends/crypto)
endef