aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-25 16:40:05 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-05 11:09:12 +0100
commit84bd74057f0d2543ddbc7de2351b0a310df329c6 (patch)
tree7c7e358aedf5930eeba27392e3123702503556e5 /package/kernel/linux/Makefile
parentdad48c6438f0a4c42ad34842a88e82280d971d90 (diff)
downloadupstream-84bd74057f0d2543ddbc7de2351b0a310df329c6.tar.gz
upstream-84bd74057f0d2543ddbc7de2351b0a310df329c6.tar.bz2
upstream-84bd74057f0d2543ddbc7de2351b0a310df329c6.zip
build: use mkhash to replace various quirky md5sum/openssl calls
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/Makefile')
-rw-r--r--package/kernel/linux/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/Makefile b/package/kernel/linux/Makefile
index 7f38f3e6e2..c2d10ec188 100644
--- a/package/kernel/linux/Makefile
+++ b/package/kernel/linux/Makefile
@@ -24,7 +24,7 @@ export SHELL:=/bin/sh
include $(INCLUDE_DIR)/package.mk
ifeq ($(DUMP),)
- STAMP_BUILT:=$(STAMP_BUILT)_$(firstword $(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | md5sum))
+ STAMP_BUILT:=$(STAMP_BUILT)_$(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | mkhash md5)
-include $(LINUX_DIR)/.config
endif