aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vmmc
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-09-17 21:45:56 +0000
committerJohn Crispin <john@openwrt.org>2013-09-17 21:45:56 +0000
commit2b0cb17d4298c9dced24ca30c5b68ce10d64c366 (patch)
treef8d7fb7770ab747709b3174abf19c9483c4cadb4 /package/kernel/lantiq/ltq-vmmc
parent07825014834a72fbdc52f193a0473a75a600e3e3 (diff)
downloadupstream-2b0cb17d4298c9dced24ca30c5b68ce10d64c366.tar.gz
upstream-2b0cb17d4298c9dced24ca30c5b68ce10d64c366.tar.bz2
upstream-2b0cb17d4298c9dced24ca30c5b68ce10d64c366.zip
lantiq: update packages for v3.10
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38028
Diffstat (limited to 'package/kernel/lantiq/ltq-vmmc')
-rw-r--r--package/kernel/lantiq/ltq-vmmc/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-vmmc/patches/200-linux-310.patch33
2 files changed, 34 insertions, 1 deletions
diff --git a/package/kernel/lantiq/ltq-vmmc/Makefile b/package/kernel/lantiq/ltq-vmmc/Makefile
index 98355b1ecd..1708652d64 100644
--- a/package/kernel/lantiq/ltq-vmmc/Makefile
+++ b/package/kernel/lantiq/ltq-vmmc/Makefile
@@ -26,7 +26,7 @@ define KernelPackage/ltq-vmmc
URL:=http://www.lantiq.com/
DEPENDS:=$(LTQ_TAPI_TARGET) +kmod-ltq-tapi
FILES:=$(PKG_BUILD_DIR)/src/drv_vmmc.ko
- AUTOLOAD:=$(call AutoLoad,25,drv_vmmc)
+ AUTOLOAD:=$(call AutoProbe,drv_vmmc)
endef
define KernelPackage/ltq-vmmc/description
diff --git a/package/kernel/lantiq/ltq-vmmc/patches/200-linux-310.patch b/package/kernel/lantiq/ltq-vmmc/patches/200-linux-310.patch
new file mode 100644
index 0000000000..70f88299f9
--- /dev/null
+++ b/package/kernel/lantiq/ltq-vmmc/patches/200-linux-310.patch
@@ -0,0 +1,33 @@
+Index: drv_vmmc-1.9.0/src/drv_vmmc_linux.c
+===================================================================
+--- drv_vmmc-1.9.0.orig/src/drv_vmmc_linux.c 2013-09-05 22:34:31.920428685 +0200
++++ drv_vmmc-1.9.0/src/drv_vmmc_linux.c 2013-09-05 22:35:54.940430772 +0200
+@@ -54,6 +54,8 @@
+ #include "drv_vmmc_res.h"
+ #endif /* (VMMC_CFG_FEATURES & VMMC_FEAT_HDLC) */
+
++#undef VMMC_USE_PROC
++
+ /* ============================= */
+ /* Local Macros & Definitions */
+ /* ============================= */
+Index: drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_linux.c
+===================================================================
+--- drv_vmmc-1.9.0.orig/src/mps/drv_mps_vmmc_linux.c 2013-09-05 22:34:31.988428687 +0200
++++ drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_linux.c 2013-09-05 22:54:01.544458009 +0200
+@@ -80,11 +80,15 @@
+ /* ============================= */
+ #define IFX_MPS_DEV_NAME "ifx_mps"
+
++#undef CONFIG_MPS_HISTORY_SIZE
++#define CONFIG_MPS_HISTORY_SIZE 0
+ #ifndef CONFIG_MPS_HISTORY_SIZE
+ #define CONFIG_MPS_HISTORY_SIZE 128
+ #warning CONFIG_MPS_HISTORY_SIZE should have been set via cofigure - setting to default 128
+ #endif
+
++#undef CONFIG_PROC_FS
++
+ /* ============================= */
+ /* Global variable definition */
+ /* ============================= */