aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vdsl
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2020-12-27 21:59:28 +0100
committerMathias Kresin <dev@kresin.me>2021-02-18 08:43:08 +0100
commitd2d32dcd5f4bb2d028452419fb2e014b7b31a37a (patch)
tree0c333b5187ce634aa0137f58ad986b418bc0d5c7 /package/kernel/lantiq/ltq-vdsl
parentba07cc0cbb3d486366e4ae3b79e69f972d8c2c5d (diff)
downloadupstream-d2d32dcd5f4bb2d028452419fb2e014b7b31a37a.tar.gz
upstream-d2d32dcd5f4bb2d028452419fb2e014b7b31a37a.tar.bz2
upstream-d2d32dcd5f4bb2d028452419fb2e014b7b31a37a.zip
kernel: lantiq: fix Module.symvers handling
If an external module uses exported symbols from another external module, Kbuild needs to have full knowledge of all symbols to avoid spitting out warnings about undefined symbols. Use PKG_EXTMOD_SUBDIRS to point to the build directory which contains the Module.symvers. Pass KERNEL_MAKE_FLAGS to the external module build, to inject KBUILD_EXTRA_SYMBOLS. KBUILD_EXTRA_SYMBOLS holds a space separated list of Module.symvers, which list all exported symbols. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/kernel/lantiq/ltq-vdsl')
-rw-r--r--package/kernel/lantiq/ltq-vdsl/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl/Makefile b/package/kernel/lantiq/ltq-vdsl/Makefile
index c09c88057f..047543496e 100644
--- a/package/kernel/lantiq/ltq-vdsl/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl/Makefile
@@ -42,6 +42,7 @@ define Package/ltq-vdsl-vr9/description
endef
MAKE_FLAGS += \
+ $(KERNEL_MAKE_FLAGS) \
SHELL="$(BASH)"
CONFIGURE_ARGS += --enable-kernel-include="$(LINUX_DIR)/include" \