aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vdsl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-05-06 17:26:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-05-06 17:26:32 +0000
commit0b89008f7f3b590653a73e98cd9eff938c2f2837 (patch)
tree5454e876f1211b9014a623f5bc7da16206441b73 /package/kernel/lantiq/ltq-vdsl
parente68687c04bdb182d72779bb54ee090381b6ef20c (diff)
downloadupstream-0b89008f7f3b590653a73e98cd9eff938c2f2837.tar.gz
upstream-0b89008f7f3b590653a73e98cd9eff938c2f2837.tar.bz2
upstream-0b89008f7f3b590653a73e98cd9eff938c2f2837.zip
ltq-vdsl: force shell to bash to avoid compile errors
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40713
Diffstat (limited to 'package/kernel/lantiq/ltq-vdsl')
-rw-r--r--package/kernel/lantiq/ltq-vdsl/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl/Makefile b/package/kernel/lantiq/ltq-vdsl/Makefile
index 0901721b90..d14d4bc955 100644
--- a/package/kernel/lantiq/ltq-vdsl/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl/Makefile
@@ -40,6 +40,9 @@ endef
EXTRA_CFLAGS = -fno-pic -mno-abicalls -mlong-calls -G 0
+MAKE_FLAGS += \
+ SHELL="$(BASH)"
+
CONFIGURE_ARGS += --enable-kernel-include="$(LINUX_DIR)/include" \
--with-max-device="1" \
--with-lines-per-device="1" \